Starting Groovy-Eclipse compiler resolver. Specified compiler level: unspecified

I got below error message while running script from console. It is showing below error message. Please let me know why is it showing error message ?

Command :

katalon -noSplash -runMode=console -consoleLog -noExit -projectPath=“C:\Program Files (x86)\Jenkins\workspace\Testing_automation_kataon\Testing_Login.prj” -retry=0 -testSuitePath=“Test Suites/SmokeTest” -executionProfile=“default” -browserType=“Chrome”

Error Message:-

Opening project file: C:\Program Files (x86)\Jenkins\workspace\Testing_automation_kataon\Testing_Login.prj
[EL Warning]: 2019-02-14 15:41:23.176–Ignoring attribute [lastRun] on class [TestSuiteEntity] as no Property was generated for it.
Starting Groovy-Eclipse compiler resolver. Specified compiler level: unspecified
166 2.4.7.xx-201611170128-e46 = ACTIVE
org.eclipse.core.internal.resources.ResourceException: Invalid project description.
at org.eclipse.core.internal.resources.Project.checkDescription(
at org.eclipse.core.internal.resources.Project.assertCreateRequirements(
at org.eclipse.core.internal.resources.Project.create(
at org.eclipse.core.internal.resources.Project.create(
at com.kms.katalon.groovy.util.GroovyUtil.initGroovyProjectDescription(
at com.kms.katalon.groovy.util.GroovyUtil.initGroovyProject(
at com.kms.katalon.groovy.util.GroovyUtil.openGroovyProject(
at com.kms.katalon.dal.fileservice.manager.ProjectFileServiceManager.openProject(
at com.kms.katalon.dal.fileservice.dataprovider.ProjectFileServiceDataProvider.openProject(
at com.kms.katalon.controller.ProjectController.openProject(
at com.kms.katalon.execution.console.ConsoleMain.getProject(
at com.kms.katalon.execution.console.ConsoleMain.findProject(
at com.kms.katalon.execution.console.ConsoleMain.launch(
at com.kms.katalon.console.application.Application.runConsole(
at com.kms.katalon.core.application.Application.runConsole(
at com.kms.katalon.core.application.Application.start(
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(
at sun.reflect.DelegatingMethodAccessorImpl.invoke(
at java.lang.reflect.Method.invoke(
at org.eclipse.equinox.launcher.Main.invokeFramework(
at org.eclipse.equinox.launcher.Main.basicRun(
Contains: OK
Contains: C:\Program Files (x86)\Jenkins\workspace\Testing_automation_kataon overlaps the workspace location: C:\Program Files (x86)\Jenkins\workspace\Testing_automation_kataon\config

Request sent successfully.


Have you tried executing the test suite in GUI mode? Does it work or encounter the same problem?

it is running successfully when I am executing from GUI mode

@poovaraj, please try the solution in this post and see if it works.

Thank you! Let me check this issue again.

Local Execution:

It is working after moving the batch file outside of the project and Config folder is generated outside of the project while running from command prompt.

Execute from Jenkins

Project is cloning from bit-bucket to Jenkins work-space when I am build job from Jenkins. How to configure batch file outside Jenkins work space ? The below command is throwing above error message.

katalon -runMode=console -projectPath=“C:\Program Files (x86)\Jenkins\workspace\automation_kataon\Test_Login.prj” -reportFolder=“Reports” -reportFileName=“report” -retry=0 -testSuitePath=“Test Suites/TS_RegressionTest” -browserType=“Chrome”

I am also facing the same problem when I am executing the katalon command through java code…but successfully execute through terminal manually…May I know why it is happening

Hi @poovaraj,

I had tried to run my TestSuite into Local Execution, but I got some issue.

I try explain my scenario:
1)Katalon Studio 7.9.0
2)Katalon Studio Engine 7.9.0
3) Folder project: C:\Users\XXXXXXXXXX\git\test-project-sample
4)Folder Katalon:

Work step By Step
1)Build my TestCase and insert it into TestSuite. I run the TestSuite with GUI Katalon Studio. It is successful.

2)I need running the TestSuite from console

2a)I go in to folder Katalon Studio Engine ( I see the file Katalonc)
2b)I copy from Katalon Studio the Build CMD

2c)paste the command


Best Regards


Please remove -apiKeyOnPremise parameter then run again.


Hi @duyluong,

I removed -apiKeyOnPremise parameter, now it’s work fine.
Anyway, my goal is to run the Suite with Jenkins. I have installed the plugin

After, I have configured my Job on Jenkins

Some problems came out

Am I missing somethings?

Best regards

Hi @AndyCapp,

First of all, please remove “katalonc” the first parameter because it is duplicated with katalonc.exe.

Back to the original issue, your Windows Jenkins does not recognize the “cmd” command so in Manage Jenkins -> Configure System -> Shell, set the shell path as

  • C:\Windows\system32\cmd.exe

Hi @duyluong,
About the original issue, I can confirm, I am able to run the suite.

I have removed “Katalonc” from setUp, you can see my setup

Unfortunately, some problems came out

for your info, following setUp Jenkins–> Configure System

Thanks in advanced