Set Text showing success message but data not entered

Versions:

Katalon: 7.0.4
My System: Windows 10 64 bit
Google Chrome: v78

I am automating a registration page that has multiple input fields all of which need to be filled out. One input field on this page is a date input in “00/00/0000” format. After updating Katalon recently for some reason the text for this particular input is not being entered when running the test. Originally I was using the “SetText” method for this and it was working fine up until now. I have tried the “SendKeys” method as well in my attempt at fixing this but no luck with that either. I don’t get any error message when this occurs, Katalon reports that this step has been completed successfully however no text has been inputted for that field. Very strange. What’s even more strange is if I re-order the test steps to make that input field entered first it will work but still fail half the time. My next step is to try with an “executeJavaScript” method if someone can provide an example for that please. Otherwise please assist with this if you can. Thanks.

I’ve come across this before. What I usually do is first click on the date field before sending keys. So I suggest you click the field, add a delay (just to see if the cursor is in the right place) before sending keys. hope this helps

1 Like

Thanks for your suggestion, unfortunately this did not work.

@rsarkisyan Can you make sure you have selected the correct selectors on the text field where you are entering text ? Can you please share the field where you are entering text ? Is the website accessible to public ?

@manpreet.mukkar thanks for your assistance. In an edit to my last comment, @mdu_kay7 solution actually worked. I forgot I switched back to the Set Text method.

Solution for my problem:

  1. add a “Click” method to click into the input field
  2. Add a 1 second “Delay”
  3. Use “Send Keys” instead of “Set Text”

Great I’m glad it worked. We should not forget we testing our application and not the browser - so at times our scripts will have such work-arounds. Thanks Mdu

Hi,
Do you have a solution for set text in the application?

Thanks!