Service endpoint undefined


I am facing issue while executing test cases from Katalon 7.6.1.

The test case calls a API method but the following error shows up:

Caused by: com.kms.katalon.core.webservice.exception.WebServiceException: Service endpoint is undefined.

When I try to run the API separately using Katalon it works fine.

Please Advice.

Hi @sureshkumar.nadar,
Please share your test script, together with the request object file (.rs file).

I ran into this problem when running test cases in Katalon 8 (8.0.5 and 8.2.5) which had originally been created in Katalon 7 (7.6.5 and 7.9.1).

2022-04-25 16:14:50.182 ERROR c.k.k.core.keyword.internal.KeywordMain - :x: Unable to send request (Root cause: com.kms.katalon.core.webservice.exception.WebServiceException: Service endpoint is undefined.

These test cases worked perfectly in version 7, but failed in version 8.

I found a workaround: Open the WebService Test Object, click off “Use the endpoint and SOAPAction header parsed from WSDL”, click it back on again, and save the Test Object.


It turns out that there are several new tags in Web Service test objects in Katalon 8, and the absence of these new tags causes the test objects to fail in version 8. The workaround is to “modify” (but not really modify) the test object and save it; version 8 will insert the necessary tags.


Editing the test object and saving it adds the missing tags, and the test object then works normally thereafter.

1 Like

Thanks - this was just what I needed to fix the same issue (scripts created in earlier version not finding endpoint when run in 8.0.5). Cheers!