sendKeys fails to send right arrow

Please let us know what you are using Katalon Studio for?

  1. I have currently applied Katalon Studio in my project

How would your work be affected if this issue has not been resolved?

  1. I can continue my job, but my performance is lower than expected

Operating System

Windows 10

Katalon Studio Version


Screenshots / Videos

Unable to send arrow keys to object.
Error on line 139
Error Msg - Unable to send keys ‘’ to object ‘Object Repository/M1-NAV_BAR/tlbrDefinitions’

Image of code

KeywordUtil.logInfo(“Navigating to [” + menuChoice + “]”)

		TestObject choice = findTestObject('M1-NAV_BAR/tlbr' + menuChoice)

		WebUI.waitForElementClickable(choice, 20)
		KeywordUtil.logInfo("Element is clickable [" + choice + "]")
		KeywordUtil.logInfo("Completed click [" + choice + "]")

		WebUI.sendKeys(choice, Keys.chord(Keys.ARROW_RIGHT))
		KeywordUtil.logInfo("Completed ARROW_RIGHT [" + choice + "]")

ArrowKeyFails-Log.txt (17.4 KB)

Hi @jim.sears,

What browser types does this issue happen on? Chrome, Firefox, or IE?

Hi @duyluong,

Version 89.0.4389.82 (Official Build) (64-bit)

FYI - I found a work around using Selenium driver and get activeElement to sendkeys ARROW_RIGHT.
The gwt tree item was not interactable directly with sendKeys but the activeElement method worked.

Even if Katalon’s sendKeys worked, it could be facing the same Selenium interactive issue. I also stepped through the code to ensure it isn’t a timing issue.

What is odd is that the current active element (get tree item) is not the “activeElement”, meaning that the later worked. What I means is that I would think current element and activeElement are the same but I haven’t proved it yet.

Please let me know if you need anything else.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.