Security Certificate Support

I’m trying to recreate our RESTful API tests that have been created in Postman in Katalon for automated nightly testing. When I configured the first GET identical to the setup in Postman, I received this error.

java.security.cert.CertificateException: No X509TrustManager implementation available

Postman uses the certificates in Chrome’s trust store to connect to the API and when I ran Postman and Katalon side by side, Postman returned a response and Katalon an error. When I first created tests for our front end web page, every time I launched Chrome with Katalon, I had to select a certificate for the test to continue. I figured out how to have Chrome autoselect a certificate based on the URL to work around that issue and now the tests run autonomously. I’m assuming the error I’m receiving is because Katalon does not have access to the certificate. Are there any known solutions at this time?

1 Like

The recommended solution will not work because the system I’m working with has implemented 2 wall SSL. Can this be an upgrade to Katalon to support certificates?

Hi Micheal,

For SSL Ceriticate validation, please enable Bypass certificate validation in Project/Settings -> Network.

Thanks

2 Likes

Facing same issue, Bypass certificate validation is not working for me.

I am also facing the same issue as show below:


But if I simply downgrade my katalon version from 5.4.2 to 5.4 (which the same object and config is used - Bypass certificate validation) - it is working well. Is there a known issue with 5.4.2 related to Certificate?

Certificate problem.jpg

1 Like

I also facing similar issue. Any update?

1 Like

I believe I managed to make it work. I downloaded the exact jre version that Katalon is using and replaced the jre folder within the Katalon installation with the new jre folder.
Then follow the instruction in https://www.java-samples.com/showtutorial.php?tutorialid=210 to install the certificate in java. For this to work do not use the Katalon bypass cerfitication option.

try Katalon Studio v6.3.3-2, i had this problem on v7, but when i try with v6 it works for me.

Bypass certification validation still not working in 7.6.2.

All tests stops at the screen with the certificate accept screen

May misinterpreted this function. To accept unsecure certificates setting acceptInsecureCerts in the desired capability setting does the job.