scrollToText not working on ios

Hi there,

I’m actually writing some test for Android and iOS applications.
After multiple test it appears that scrollToText seems to not working on iOS (but it work perfectly on Android).

I’m using :

  • Appium : 1.15
  • iOS : 11.2.5
  • Katalon : 7.2.1
  • Running on MacOS 10.14.6

Does anybody have encountered this issue before ? There is no error log, the test just stop at this line and stay there an infinite time!

Here is the line of code

Mobile.scrollToText(myChannel[i])

Where myChannel is an array with all the string I want to scroll to.

I’ll be glad if someone has already see this issue and know how to fix it!

Thank you

UPDATE :
I just figure that my ios element don’t have any “text” property but only “label”, “name”, and “value”. So my question now is, do you know if there is a other way to scroll to an element or do I have to implement my own solution ?

use action
import org.openqa.selenium.interactions.Actions as Actions

Actions action = new Actions(driver)
action.moveToElement(YourElement-here).perform()

Thank you for the answer ! But I’m new in this kind of development so could you please details what “driver” is ? I assume it’s AppiumDriver<?> driver = MobileDriverFactory.getDriver() ?

And how am I suppose to pass the element ? I’ve tried this but it’s not working

TestObject testObject = new TestObject()
testObject.addProperty("value", ConditionType.EQUALS, myChannel[i])
action.moveToElement(testObject)

The error says that it don’t recognize the signature and propose me to try with a webElement (Which I don’t have because I’m on iOS…)

Hi @anthony.ierace
I’m also facing the same issue and I tried adding text Properties with value to one of the Object but still Katalon is not able to identify and my test case keeps on failing with "Unable to scroll to text ‘Certification’ "
Error: Failed to perform scroll with visible cell due to max scroll count reached

Hi,

As i use WebDriver, Here is my code. This scrolls in the page till the object.

    WebDriver driver = DriverFactory.getWebDriver()
Actions action = new Actions(driver)
action.moveToElement(driver.findElement(By.xpath("YOURXPATH"))).perform()