Quotes in URL is throwing 400 Bad Request error

Hello,

This is my first post and I have been trying to test a rest service that has quotes in the request, see below.
http://server/api/unit/number=“ABC123”.

The same request is working in Postman, but all the URLs that have quotes are failing with the same “400 Bad Request” error.

I see that this URL is converted as follows in “.rs” file.
http://server/api/unit/number=“ABC123”.

I tried different combinations but I still got the same error.
I am using 5.10.1 version, which is the latest as of now 01/18/2019.

I would appreciate your help. I am trying to do a POC, this would help a lot.

Thanks,
Karun

@Loan_Tran @Alice Please advice.

@kogirala Can you send me the url which can access? And your url must have question mark between parameter and url. let’s put it at your url and double check again.

Hi Alice,

Thank you for replying to my question.
These URLs are set up this way and are working with POSTMAN application. I am running into this error only when I use Katalon.

URL looks like below:-
http://server/api/unit/number=“ABC123”.

It started working when I replaced quotes with ‘%22’, instead of ‘"’.
I am not sure how Katalon is handling this conversion but literal quotes will fail with Bad Request, only ‘%22’ replacement of quotes work.

I hope this help and once again thank you for your reply.

Karun

Thank you @Alice, @devalex88 for responding.

I was able to fix this issue by replace quotes with ‘%22’ instead of ‘"’ in the URL string.

I appreciate all your help.

Thanks,
Karun

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.