Problem while trying to run Katalon in a Docker container


#1

Hello, is there some problems with the Katalon image for Docker? when I try to execute the Firefox browser as a headless test case execution, instead of showing the detailed steps that Katalon is executing I can see only this message:
image

Am I doing something wrong?, cause I followed the same steps that are described in this link https://docs.katalon.com/katalon-studio/videos/katalon_run_docker_container.html, but no success.


#2

It seems like something is wrong in your command. can you share the command you used


#3

Hello, the command that I put in the Terminal is ./KatalonDocker/run_firefox.sh , but inside the script the lines are:
#!/usr/bin/env bash

rm -rfv ./reports/firefox
mkdir -p ./reports/firefox

katalon_opts=’-browserType=“Firefox” -retry=0 -statusDelay=15 -testSuitePath=“Test Suites/FastTest”’
docker run --rm -v $(pwd)/KatalonDocker:/katalon/katalon/source:ro -v $(pwd)/reports/firefox:/katalon/katalon/report -e KATALON_OPTS="$katalon_opts" katalonstudio/katalon


#4

does Mac have bash? i thought is using zsh …
sorry, i don’t have such device to test your script (and my wife told me it will cut my fingers if i dare to touch hers, because i tend to ‘linuxize’ everything), so it’s just a guess …


#5

Hello @Ibus, I have the same problem in Linux while trying to run the script,


It seems that instead of running my script it only shows me the browsers version.
This is the code:
#!/usr/bin/env bash

rm -rfv ./reports/firefox
mkdir -p ./reports/firefox

katalon_opts=’-browserType=“Firefox” -retry=0 -statusDelay=15 -testSuitePath=“Test Suites/FastTest”’
docker run --rm -v $(pwd)/KatalonDocker:/katalon/katalon/source:ro -v $(pwd)/reports/firefox:/katalon/katalon/report -e KATALON_OPTS="$katalon_opts" katalonstudio/katalon


#6

@jorge.montano
mhm … looking deeper i see you try with a desktop browser. try a headless driver (firefox or chrome, feel free to choose)
being inside the container, i don’t think it can allocate a real graphical display, but a tty only.
if still fails we will dig more, but 90 % this is the root cause for your issue
the script seems to be right for the rest (provided the path to the test project is correct)


#7

@Ibus, are you referring to the nex code?:

Or what do you recommend to me?


#8

@jorge.montano ahem. try that and let’s see how it behave
LE: abort! the headles option should be inside the quotes. e.g. “Firefox headless”. that full named option of browserType is the driver selector at runtime
‘headless’ is not a katalon option but an execution choice, related to available drivers.


#9

The following is the command to use

docker run -t --rm -v "$(pwd)":/katalon/katalon/source katalonstudio/katalon katalon-execute.sh -browserType="Chrome" -retry=0 -statusDelay=15 -testSuitePath="Test Suites/TS_RegressionTest"