Override Execution Profile variables via the CLI is not working

Override Execution Profile variables via the CLI is not working

I have created 2 Global Variables g_URL and Password and I am trying to overwrite the values of these 2 Global Variables by passing the values via the CLI using below cmd. But default values in profile are not getting overwritten with the supplied values from CLI. Can you please help on this?

katalonc.exe -runMode=console -consoleLog -projectPath=“E:\Auto\Automation\API\KatalonAPITesting.prj” -statusDelay=5 -retry=0 -testSuiteCollectionPath=“Test Suites/New4” -apiKey=“5d8ba9d8-45bd-4815-8145-cb25cb1cf8f1” -orgID=161836 -testOpsProjectId=154538 --config -webui.autoUpdateDrivers=true -sendMail="Rajesh.Guduru@sumtotalsystems.com" -licenseRelease=true -executionProfile=“default” -browserType=“Chrome” -g_URL=“https://xxxx.sumtotaldevelopment.net” -Password=“xxxxxx” -reportFolder=“E:\Katalon\API_Reports”

Operating System - Windows 10

Katalon Studio Version : KRE 8.0.0

Screenshots

How would your work be affected if this issue has not been resolved?

I can continue my job, but my performance is lower than expected

The parameter to override Global Variable in Execution should start with “-g_” then your parameters should be:

-g_URL=“https://xxxx.sumtotaldevelopment.net” -g_Password=“xxxxxx”

instead of

-g_URL=“https://xxxx.sumtotaldevelopment.net” -Password=“xxxxxx”
1 Like

Thank you.Got the solution…In execution profiles we have to create variables without -g as prefix(ex : URL). We have add prefix “-g_” to override parameter value via CLI. We have to supply -g_URL via CLI for variable URL