Official Release - Version 8.0.1

This is a companion discussion topic for the original entry at

The Download Link is still version 7.9.1

Viewed the Release Highlights from within Katalon studio start page. The start page says version 8 is available, but when I click on the upgrade link, get a messages that I am up to date with version 7.9.1. So is there really a version 8?

Hello everyone

Please try downloading our latest version - 8.0.1 from website. Due to an internal issue, v8.0.0 was rolled back to v7.9.1. We apologise for any inconvenience this may have caused.

Happy Testing


Hello, launching this call:
WS.verifyElementPropertyValue(response, ‘.//multiRef/esito’, ‘OK’)

I get the following error:
Caused by: java.lang.IllegalArgumentException: Property ‘http://javax.xml.XMLConstants/property/accessExternalDTD’ is not recognized.
I read on the net that this is an anomaly. Confirm?

Katalon 8.0.1


I am sure v8.0.1 has a problem. Have a look at the following post for detail:

HI @kazurayam, @gabriele.lupoli,

Caused by: java.lang.IllegalArgumentException: Property ‘http://javax.xml.XMLConstants/property/accessExternalDTD’ is not recognized.

This is an issue of Katalon Studio in v8.0.1. We are planning to fix this.
The workaround, for now, is to put this script at the beginning of the test case or @BeforeTestCase method of a test listener:


Thanks for the answer and the suggestion. With the workaround I get this other error:
Caused by: java.lang.RuntimeException: Lo spazio di nomi per il prefisso ‘soapenv’ non è stato dichiarato.
I noticed that it is the same case reported here:

My response is:

<?xml version="1.0" encoding="UTF-8"?>

<soapenv:Envelope xmlns:soapenv=“” xmlns:xsd=“” xmlns:xsi=“”>
<ns1:activateLineResponse soapenv:encodingStyle=“” xmlns:ns1=“”>


Do you have any suggestions?

In KS 8.1.0 when I execute a suite with Variable binding, I see this message:

Azure: Enterprise license for this feature is requested

Are you referring to the KSE license? Wonder why I read Azure.
Thank you.

Why on earth did you guys remove the Create Script Repository and Update Script Repository options?! Now I have to downgrade to version 8.2.0 and face the annoying “Truncated class” error again. One step forward, two steps back.

Why remove Create Script Repository and Update Script Repository ?! I need these options !! I have tried to do this trough the TestOps web site and it does not work. We have a local gitlab and even if I tried to create access tokens it does not work !! I am forced to go into a test suite collection and choose “Schedule on TestOps” which now creates new entries in testops instead of just updating the repository…

Hi @paudet and @kaique.silveira, thank you very much for your feedback.
We understand that it might be frustrating that something you have found convenient is no longer supported, but please let me explain the reason behind it.

We are in the process of deprecating the functionality of uploading test scripts as zipped files onto TestOps for execution. We want to encourage our users to follow the industry best practice of storing code/scripts under version control systems. We have spent significant effort in the recent releases to support native integrations with GitHub, BitBucket, GitLab, Azure Repos, and Amazon Codecommit (coming soon this month). Please check our docs for integration setup instructions. After the script repo integration, you can browse test cases, test suites from your script repo and can even create/execute new test suites directly on TestOps.

@kaique.silveira: if you are not using version control, we encourage you to do so. If your version control is not on the supported list yet, please let us know.
@paudet: we will look into supporting self-managed GitLab. Meanwhile, you can still upload zipped files onto TestOps following the instructions here, it should work exactly as the upload button in Katalon Studio.

Thank you very much for your support of our products.

Best Regards,
Katalon Team.