Not able to Type < , > and . characters with katalon studio

Hello ,

It happens when I run the test case and occurs when Katalon performs setText and the text contains the character ‘<’ or ‘>’ or ‘.’ .It writes everything except those characters .

How could i solve this problem ?

it works fine for me in chrome or edge, what navigator are you using?

I used both chrome and edge

Please provide us with more information like some code.

it works for me, could you try it in another input like the google page?, maybe is the web page that you are working on.

hi there, i think the issue comes from using html type decimal.
if you have an input like this, it could not work for you
input type=“number” name=“number” step=“any”

1 Like

I used :

WebUI.setText(findTestObject(‘Object Repository/Recherche/Page_Open Bee Portal Administrator/input_Montant’), ‘1899,10’)

and this is my input :

i still have the same error

can you writte the character manual in to the input?

Yes

image

You may need to use a combination of Set Text and Send Keys in order for this to work

@qa.team

You typed 1899.5 (with a dot) manual in to the INPUT field.

On the other hand, your script sends 1899,5 (with a comma).

Which do you really want?

1 Like

I want 1899.5 (with a dot)

So why don’t you use

WebUI.setText(findTestObject('Recherche/Page_Open Bee Portal Administrator/input_Montant'), '1899.10')

with the dot you want ?

I have already tested it but i still have the same error

WebUI.setText(findTestObject('Object Repository/Recherche/Page_Open Bee Portal Administrator/input_Montant'),  '1899.5')

image

@qa.team,

Katalon’s WebUI.setText() never does this sort of text translation: ‘1899.5’ to ‘18995’.

There must be some other player unseen yet. I guess, your input field “Montant” is associated with an event handler function in JavaScript which accepts input of ‘1899.5’ and translates to ‘18995’.

2 Likes

I agree with @kazurayam