No longer able to execute test suites via command line (or .bat file) or through Team City

In the old Katalon builds this used to work very well. However, newest Katalon versions (builds) do not allow us to run test suites via .bat files or through Team City.
No matter what we do, the following error shows up:
I’m not giving below the correct URL but just trust me that on Katalon v.5.0 and (before that) this worked just fine. Now something happened.

Full Name: All test cases/Test Cases/Xpress/Login/Valid login inputs

Start / End / Elapsed: 2018-04-09 17:57:58.234 / 2018-04-09 17:58:01.877 / 00:00:03.643

Status: FAILED

Message: Test Cases/Xpress/Login/Valid login inputs FAILED because (of) Unable to open browser with url: ‘’ (Root cause: java.lang.IllegalAccessError: tried to access method;)V from class

NO MATTER what URL one uses, this always ends up with an error.

  1. Create a bat file by using the ‘Generate command for console mode’ feature in Katalon
    An example:
    katalon -noSplash -runMode=console -projectPath=“C:\Users\git\MyBranch\xpress-katalon\Our projects.prj” -retry=0 -testSuitePath=“Test Suites/Xpress suites/All test cases” -browserType=“Chrome”

  2. Try to run the .bat file and execute the test suite

  3. Run the same test suite via Katalon interface to make sure that the suite might be actually executed


Does this happen for ‘Open Browser’ keyword or ‘Navigate to URL’ keyword?

I’m running into the same issue. It happens for Open Browser

1 Like


Attached is a .zip file ( that is a Katalon Studio “Test” project folder and files created using Katalon Studio Windows 64 v5.4.1…

Also attached is a batch file (KatalonStudio-TestProject.bat), that has been renamed as a text file, that executes Katalon Studio from the command line (Adjust the locations as appropriate on your PC)…

Try running “New Test Script” Test Script from the command line on your PC…

P.S. In the “C:\Katalon Studio\Test\Reports\New Test Suite\20180510_165231\videos\” folder is a video showing the command line executing on my PC…


David, I am using Katalon on MAC
Any help there ?

@Vinh Nguyen,