Language Issue

Iam new Comer to Katalon Studio. Iam Testing for web in Manual mode. When i open with chrome or firefox Browser My Language does not reset to English Even though i changed System settings everything i did But it opens with Arabic Language.
Example :
My country is united Arab Emirates so it default shows with arabic Langauge but i wanted to show my test cases in English. So kindly tell me the Procedure.

Similar issue:

thanks for the update tried everything what its mentioned in the Post But still its not working for me.

1 Like

Let me tell you what I have done.

My platform is

OS: Windows 7, default language ja_JP
Browser: Firefox 62.0.3
Katalon Studio 5.7.1

I made a test case:

import com.kms.katalon.core.webui.keyword.WebUiBuiltInKeywords as WebUI

This just opens Google Search Result with query for “katalon”.

In Katalon Studio, Comman bar, select Project >Settings>Execution>Default>WebUI>Firefox. In the dialog, add
Name: firefox_profile
Type: Dictionary
Value: { “intl.accept_languages”: “en” }

Specifying ‘intl.accept_languages’ property as “en” to Firefox means that HTTP Header “Accept-Language” to have value “en”. The header is sent from Firefox to GoogleWeb.

See the screenshot attached

When I ran the test case, Firefox browser opened.

The responded Google page was in Japanese = the locale of my PC’s OS. However I noticed in the right upper side, a message asking me: Do you want to look results in English?

When I click the Change to English the page is redirected to English view.

This seems that specifying Firefox property ‘intl.accept_languages’ property to be “en” is a valid approach. Google acknowledged that I want to see the search result in English.

However Google is prudent enough in dealing with requests to change the language (from the default to the one specified by Accept-Language). It requires me to click the anchor to confirm the language. I can not control the behavior of Google at all. Manually clicking the link obviously disturbs test automation.

Conclusion: this approach is not very good.

By the way, the simplest way might be re-installing your Browser with language=en

今日はAPIのテストをしました、でもresponse bodyのなかで日本語を表示できませんでした、日本語の方が全部文字化け、どうしますか?よろしくお願いします

I need to reproduce your problem on my side. Could you please share your project here? I need to see your test case, test object (including the URL of target application, URL parameters etc).

You may need to check if the HTTP Response Headers of your UAT is confirming to the way how to respond contents with muti-bytes characters. Is the Content-Type header OK? Is it like this?

Content-Type: text/plain;charset=Shift_JIS

If no Content-Type header is responded, you would certainly see garbled charcters in most of HttpClients including Katalon Studio.

for explanation in 日本語

thank you for you reply ,i tried to add the HTTP Header like this image but it didn’t solve the problem ,did i make a mistake?

and i tried to use postman client to do an api test ,that japanese in reponse body is ok , that Content-Type →text/html; charset=UTF-8 , the same to katalon studio …

I am confused.

Are you saying that you found Content-Type text/html; charset=UTF-8 in the actual response headers of your UAT?

If so, the response should be HTML, not JSON or XML. Is it what you intend?