KeyEvent doesn't work after update to Katalon 7.7.1

I have code to upload file in katalon using KeyEvent, i used katalon 7.6.0 before and it worked perfectly then i update katalon to version 7.7.1 but KeyEvent doesn’t work
This is my code :

Operating System

  • MacOS Catalina

Katalon Studio Version

  • Katalon Studio Enterprise 7.7.1

@chaidir04121990

Hi, how is it not working ? Is it throwing any error, any log message ?

It doesn’t throw any error in chrome but those keyEvent doesn’t work there is like nothing press from the keyboard.
and i tried also in firefox then it throw error like this :slight_smile:

2020-09-24 12:05:53.795 ERROR c.k.k.core.keyword.internal.KeywordMain - :x: Unable to switch to window with index: ‘0’ (Root cause: com.kms.katalon.core.exception.StepFailedException: Unable to switch to window with index: ‘0’

Caused by: org.openqa.selenium.InvalidArgumentException: Expected “handle” to be a string, got [object Undefined] undefined

Build info: version: ‘3.141.59’, revision: ‘e82be7d358’, time: ‘2018-11-14T08:25:53’

System info: host: ‘M-Chaidir-Pratama.local’, ip: ‘fe80:0:0:0:71:b31f:3b07:ba2f%en0’, os.name: ‘Mac OS X’, os.arch: ‘x86_64’, os.version: ‘10.15’, java.version: ‘1.8.0_181’

Driver info: com.kms.katalon.core.webui.driver.firefox.CGeckoDriver

Capabilities {acceptInsecureCerts: true, browserName: firefox, browserVersion: 80.0.1, javascriptEnabled: true, moz:accessibilityChecks: false, moz:buildID: 20200831163820, moz:geckodriverVersion: 0.23.0, moz:headless: false, moz:processID: 19039, moz:profile: /var/folders/0s/4_d154xd6dq…, moz:shutdownTimeout: 60000, moz:useNonSpecCompliantPointerOrigin: false, moz:webdriverClick: true, pageLoadStrategy: normal, platform: MAC, platformName: MAC, platformVersion: 19.0.0, proxy: Proxy(direct), rotatable: false, setWindowRect: true, strictFileInteractability: false, timeouts: {implicit: 0, pageLoad: 300000, script: 30000}, unhandledPromptBehavior: dismiss and notify}

Session ID: 492931ea-d634-cb4d-a15c-e5c65727cf12

2020-09-24 12:05:53.800 ERROR c.k.k.c.c.keyword.CucumberReporter - :x: Upload file “new_captcha1500.png” FAILED.

but, beofre this it worked fine in katalon 7.6.0
I just tried in katalon 7.6.0 and it worked fine, here is the prove


so guys, i think there is something that must be fixed in katalon 7.7.1

the firefox issue, at least, has to do with the geckodriver version, try fetching the latest manually(and replacing the one katalon uses), since the ‘update driver’ using the katalon user interface doesn’t fetch the correct version

Hi Kenzie,

We have 8.1.0 available to download, kindly try and we can work out more on this if the problem reoccur.

Thank you,
Chris