Katalon test case wont run on iPad simulator


#1

Hello!

I am trying to use katalon studio for my automation. My first task is to automate taking screenshots in various areas of the app (for appstore submission).

I have written such test case, and it runs nicely for me on iPhone simulators. But when I select any of iPads, it fails. It fails to launch the simulator (please note that all the settings are still the same - works for iPhone, does not for iPad).

I suspect the reason is that Katalon does not tell appium which sim to launch? Bcs there are four iPads, but katalon just does not see the difference (9.7 inch, 12.9 inch 2nd gen., 12.9 inch 3rd gen…) - Katalon just lists all of them as “iPad pro (simulator)”.

Also when I run the test case for phones, I see the device id in the Job Progress window, but if I run the same for iPad, I dont see the device id, but I see 12.9 inch instead.

I think it might be linked to https://18.233.120.220/t/ipad-pro-9-7-inch-simulator-not-launching-correctly/12870 that nobody bothered to answer.

I need a way to run my test suite on iPad Pro 12.9 inch, 2nd gen., bcs screenshots from this device are requirement for my task to be complete.

Any ideas? I can provide any logs necessary.

MacOS Mojave
Katalon Studio 6.1.0
Appium 1.8.1
xCode 9.4.1


#2

Okay, update:

I have updated to xCode 10.2, appium 1.12.1 and Katalon Studio 6.2.0 (release candidate)

Still same issue, but logging is nicer now, so I can better pinpoint where the error happens:

In the logs I see:

Test Cases/TakeScreenshotsForStore FAILED.

Reason:

com.kms.katalon.core.exception.StepFailedException: Unable to start app at: ‘xxx-path-to-app’ (Root cause: org.openqa.selenium.SessionNotCreatedException: Unable to create a new remote session. Please check the server log for more details. Original error: An unknown server-side error occurred while processing the command. Original error: Could not create simulator with name ‘appiumTest-ACA43FDD-A1CB-4F4E-9716-3D2857286AD2-iPad Pro’, device type id ‘iPad Pro’ and runtime id ‘12.2’. Reason: ‘simctl error running ‘create’: Invalid device type: iPad Pro’

but if I run xcrun simctl list I see the these entries (among many others) at iPad Pro:

== Devices ==
– iOS 12.0 –
– iOS 12.2 –
iPhone 5s (E906BEB9-3D6C-4CD3-8109-AA7AB84DFE0A) (Shutdown)
iPhone 6 (8959182C-1E29-4537-8382-60EB3DD4B445) (Shutdown)
iPhone 6 Plus (55AEDD34-A02D-4561-8410-468854224F45) (Shutdown)
iPhone 6s (DE7EDCCC-5463-457E-BED6-829A98F6F5F8) (Shutdown)
iPhone 6s Plus (BF66468D-8428-43C9-A62A-E08D392AA521) (Shutdown)
iPhone 7 (844CD591-B728-45AA-9E67-F25DF3F94B4C) (Shutdown)
iPhone 7 Plus (FCCC6E1F-8C48-48E3-839B-6AEC7D26400D) (Shutdown)
iPhone 8 (F69BF8EA-D15C-4997-9ABC-8D1EE7091A8A) (Shutdown)
iPhone 8 Plus (FB0577F0-7810-4DF9-83E5-89FD4314E326) (Shutdown)
iPhone SE (BF6124F7-2979-42E4-99A8-B50EBBDE3139) (Shutdown)
iPhone X (F6B45FD7-133D-40B9-BD46-86D544ADBA49) (Shutdown)
iPhone Xs (3DF3AC14-E6A5-4BD9-AA72-A088C4C34153) (Shutdown)
iPhone Xs Max (28AD4A87-A571-4974-A703-FAA38E7A06BD) (Booted)
iPhone Xʀ (CB084677-2FDD-4877-8DD9-E437DAE7F7A7) (Shutdown)
iPad Air (3rd generation) (8EA0DFCF-1B8F-4AC9-9FA1-CA7738906257) (Shutdown)
iPad Air (1211DA84-3361-4317-84DE-F068D6CC8F1E) (Shutdown)
iPad Air 2 (9570DBB2-4AB4-41CE-B8A9-22E0BD5FFAA5) (Shutdown)
iPad (5th generation) (5479EA59-92B3-4CC9-B4AE-1528975FA26D) (Shutdown)
iPad Pro (9.7-inch) (AC2E46FF-1D62-456B-A062-AB697CB011D4) (Shutdown)
iPad Pro (12.9-inch) (1B62FBE4-0528-41E8-8404-E0D65149053F) (Shutdown)
iPad Pro (12.9-inch) (2nd generation) (4155678F-3FB3-4DBF-9B31-3D502661FEA7) (Shutdown)
iPad Pro (10.5-inch) (0A1771A7-455F-4BC5-9401-1A3C248CD95D) (Shutdown)
iPad (6th generation) (16CF2223-0BF5-4CF2-B7FA-1298D6DDEE21) (Shutdown)
iPad Pro (11-inch) (DA70F4EE-E4EF-48AC-8EF2-D036E546E644) (Shutdown)
iPad Pro (12.9-inch) (3rd generation) (C5A19346-822D-47F3-B73D-D71FD94365A3) (Shutdown)

none of these matches the id from the Katalon’s Log Viewer (the session tried to launch sim with id ACA43FDD-A1CB-4F4E-9716-3D2857286AD2 …

I hope this helps with debugging, since I am lost on this one.

Thank you


#3

Hi @dominik.pokora,

Do you have any other versions of Xcode on your machine? It’s odd that the device id ACA43FDD-A1CB-4F4E-9716-3D2857286AD2 doesn’t show in your list at all, so maybe it’s coming from a different Xcode installation?

To switch Xcode installations, you can use:

sudo xcode-select -s /Applications/Xcode.app/Contents/Developer

where Xcode.app is the location of your Xcode 10.2 install.

Hope this helps,

Chris


#4

Hello,

yes, I have the xcode 9.4.1 and 10.2 (bcs that is the way you guys said its possible to run tests with Katalon, when it didnt support xcode 10).

It matters not if I choose either of xcodes, the error is still the same. Katalon Log viewer says:

Original error: Could not create simulator with name ‘appiumTest-C83989CF-6CE0-417A-89E7-DE0102D45943-iPad Pro’, device type id ‘iPad Pro’ and runtime id ‘12.2’.

The name ofc changes depending on what simulator I run (although there is no way of telling in Katalon - all of them are just iPad Pro Simulator…), and what version of xcode.

But no matter which xcode I choose, I still cant run tests on iPad Pro


#5

I chose xcode 9.4.1, but I still can’t run tests on the iPad 2018. I don’t know if it is a bug. Does anyone know how to run my test on iPad model?


#6

Hi @HalenoZodygg,

  • If your iPad iOS version is 11.x, you can run with the current Katalon Studio version 6.1.2.
  • If your iPad iOS version is 12.x or later, please upgrade your XCode to 10.2 and try this beta.

Thanks.