Katalon sends weird symbol instead of deleting text in FireFox

Hello, I need help.

I’m using the folowing sequence instead of Clear Text command witch doesn’t work for some reasons both in Chrome and in FF:

  • WebUI.doubleClick(findTestObject(‘MyTestHomePage/Reg_PopUp/input_registration-name’))

  • WebUI.delay(3)

  • WebUI.sendKeys(findTestObject(‘MyTestHomePage/Reg_PopUp/input_registration-name’), Keys.chord(Keys.BACK_SPACE))

And the sequence worked well in both Chrome and FF. For now, it works in Chrome, but in FF it sends weird symbol to the input instead of the last letter witch was shown in the textbox. I also tried to use sending the “Ctrl+A” and Backspace/Delete combination or the “Ctrl+A” and “a” and Backspace combination. This doesn’t work as well, the weird symbol still showing itself on at the textbox, when I need to completely empty input.

I replaced the geckodriver for the newest as well. Still don’t work. Any suggestions, please?

1 Like

Hi Ignatius,

did you try simply to set a blank string to the field to make it clear? Like this:

WebUI.setText(findTestObject('MyTestHomePage/Reg_PopUp/input_registration-name'), "")

Hi, Marek.

I tried it after your suggestion. It doesn’t work (in Chrome as well).

Thank you very much.

Hmm, that is weird. Can you provide your code? Is it Angular app?

Hi,

I"m also getting that weird character

0.0.15

WebUI.doubleClick(findTestObject(‘Page_Setmetrics - Energy Service Co - CreateFIM_UpgradePTHP_ConstantSpeed/input_SupplyFanPressureRise’))

WebUI.sendKeys(findTestObject(‘Page_Setmetrics - Energy Service Co - CreateFIM_UpgradePTHP_ConstantSpeed/input_SupplyFanPressureRise’), Keys.chord(Keys.DELETE))

WebUI.clearText(findTestObject(‘Page_Setmetrics - Energy Service Co - CreateFIM_UpgradePTHP_ConstantSpeed/input_SupplyFanPressureRise’))

WebUI.setText(findTestObject(‘Page_Setmetrics - Energy Service Co - CreateFIM_UpgradePTHP_ConstantSpeed/input_SupplyFanPressureRise’), ‘0.15’)