Katalon runtime engine error in linux ec2

Hi
I am trying to run a testsuite over a Linux ec2 machine and i had a katalon runtime engine node licence. I have downloaded the katalon project in which i need to run a testsuite and also katalon runtime engine linux in my ec2 machine along with java as stated in the document - https://docs.katalon.com/katalon-studio/docs/install-RE.html#download-kre.

When i run the command to run the testsuite i was getting this error related to chromedriver.
The command i am using is - ./katalonc -noSplash -runMode=console -projectPath="/home/ec2-user/katalon/testautomation" -retry=0 -testSuitePath=‚ÄúTest Suites/ChromeHeadlessTest‚ÄĚ -executionProfile=‚ÄúPROD‚ÄĚ -browserType=‚ÄúChrome (headless)‚ÄĚ -apiKey="my api key"

The error im facing is -
/home/ec2-user/katalon/Katalon_Studio_Engine_Linux_64-7.8.1/configuration/resources/drivers/chromedriver_linux64/chromedriver: error while loading shared libraries: libX11.so.6: cannot open shared object file: No such file or directory.

can someone help me with this issue.

@kazurayam @Brandon_Hein can you guys help me with this if you have know the issue.

Thanks in advance.

I am not sure, but possibly you need to install libX11.so.

I could find some more information by Google Search by ‚Äúchromedriver: error while loading shared libraries: libX11.so‚ÄĚ

For example

sudo yum install -y libX11

Hi @kazurayam
Thanks for the quick reply. I have installed libX11 and tried running the testsuite again but i got a new issue.
The issue is -Starting ChromeDriver 87.0.4280.88 (89e2380a3e36c3464b5dd1302349b1382549290d-refs/branch-heads/4280@{#1761}) on port 16581
Only local connections are allowed.
Please see https://chromedriver.chromium.org/security-considerations for suggestions on keeping ChromeDriver safe.
ChromeDriver was started successfully.

I think you can safely ignore that message, as I also see that message all the time I execute my test in KS free version.

Sorry, I did not give the complete context of the issue in the previous message. Sorry for that @kazurayam .
but after those messages, the test suite still failed to run because of the chrome.

@srianoop.d now you have to install chrome :smiley:

What OS did you choose for your ec2 instance?
Just for curiosity…
However, for such setup, i will recommend to run your project using the docker image, not kre standalone.
The docker image should be backed with everything needed and provide a better isolation from the underhood OS, the only needed is to have docker installed (and most of the ec2 flavours should have it already in place)

1 Like

Thanks @bionel
I will use the docker image.