Katalon Linux - Test Suite Report is Not getting generated

I have set up Katalon Test Suite on Linux machine. My use case: I want to email Katalon Report but my report is not getting generated in Katalon.

I have installed different versions and tried with 5.0.1, 5.9.0 and 6.0.1 Version

Report Directory has execution files

Html report file is expected

NoTE:I have test suite setup which generates reports

any luck on this? I am facing the same issue!!

Yes Rajeshari.

I was unable to get report in by default report folder.Hence I fixed it defining report name and report location.

reportFolder="/root/katalon/katalon_automation" -reportFileName="$new_fileName

Sending command line for your reference.

cd /root/Katalon_Studio_Linux_64-6.0.6
./katalon noSplash -runMode=console -consoleLog -projectPath="/root/katalon/katalon_automation/katalon_automation.prj" -testSuitePath="/Test Suites/OrbiGo_V2.5/BTO_TVT/BTO_TVT" -browserType=“Chrome (headless)” -reportFolder="/root/katalon/katalon_automation" -reportFileName="$new_fileName"

Hope this helps!

Thanks, Palak for such a quick response.

it stil is not working for me. Te error is :-1:
joptsimple.MultipleArgumentsForOptionException: Found multiple arguments for option reportFolder, but you asked for only one

But I don’t have any settings defining the report folder ( checked internal settings files)