javax.xml.stream.XMLStreamException: ParseError

.log.zip (3.9 KB)

Hi,

as far as I know the problem does occur with latest Katalon Update to 7.7.2.

After a testrun, I get this error
“javax.xml.stream.XMLStreamException: ParseError…”

In the testlog file execution0.log (339.0 KB) a full line of “NUL” is added during the Katalon report process.

No JUnit file will be created and I do not see the results in the “Result” section in the testsuite.

Although the testcases did run perfectly in the past, I checked each and every testcase for unknown characters anywhere but with no luck.

Please have a look on it and get back to me if I can give you more information in any way.

Thanks in advance

Please let us know how would your work be affected if this issue has not been resolved?

  1. I cannot continue my job and have to work on something else while awaiting your response

Operating System

  • Windows 10

Katalon Studio Version

7.7.2

Katalon Studio logs

  • Windows logs folder: \config.metadata.log
    attached.

Screenshots / Videos

  • Please attach screenshots or videos if necessary to reproduce the issue

Ok, 10 days later. The issue still persists and I can not continue anything without fixing this one.
I tried a whole lot of things already but it seems nothing will resolve the issue:
. Checking all testcases for issues
. Roll back to previous versions of my testcases - even far back where for sure everything worked fine
. re-creating of all testsuites
. re-set of all settings in Katalon, preferences as well as project specific
. get an older Katalon build 7.7.1
. checking java installations (all removed as it is in Katalon)
…and a lot of tiny adjustments which could have been an issue although testcases were working fine until now

There are two observations:
. When starting Katalon for the first time after a restart of the laptop I get an error message


. after resetting everything the suite will succeed one single time with these warnings showing up in the Event log EvenLog771FirstRunManagement.txt (78.1 KB) - again, with these statements the suite will succeed! - Once! Afterwards its going back to the parse Error.

Slowly I get to the point where I don’t know how to move on.

I am not saying that it is not a problem in my testcases but there is no way to debug it as the fail comes afterwards during parsing of the results.

Please, if anybody have the slightest idea where I should take a look, tell me.

Hi @Alexander_Heinz,

Please share your report folder includes the execution.log file.

You can send it in private chat if your data is sensitive

Hi - has there been any follow up to this please? One tester has an issue where report appears to be generated but cannot be viewed in Katalon. Running 7.7.2.
An entry in the log reads:
Thu Oct 22 16:52:37 BST 2020
javax.xml.stream.XMLStreamException: ParseError at [row,col]:[157848,1]
Message: An invalid XML character (Unicode: 0x0) was found in the element content of the document.
at com.sun.org.apache.xerces.internal.impl.XMLStreamReaderImpl.next(XMLStreamReaderImpl.java:604)
at com.kms.katalon.core.logging.TestSuiteXMLLogParser.processFile(TestSuiteXMLLogParser.java:85)
at com.kms.katalon.core.logging.TestSuiteXMLLogParser.readTestSuiteLogFromXMLFiles(TestSuiteXMLLogParser.java:62)
at com.kms.katalon.core.reporting.ReportUtil.generate(ReportUtil.java:445)
at com.kms.katalon.core.reporting.ReportUtil.generate(ReportUtil.java:455)
at com.kms.katalon.execution.launcher.ReportableLauncher.prepareReport(ReportableLauncher.java:353)
at com.kms.katalon.execution.launcher.ReportableLauncher.preExecutionComplete(ReportableLauncher.java:144)
at com.kms.katalon.execution.launcher.ProcessLauncher.onWatchdogComplete(ProcessLauncher.java:194)
at com.kms.katalon.execution.launcher.LaunchWatchdog.notifyProcessTerminated(LaunchWatchdog.java:136)
at com.kms.katalon.execution.launcher.LaunchWatchdog.run(LaunchWatchdog.java:66)
at java.lang.Thread.run(Thread.java:748)

Thanks
Dan

Hi @Dan_Bown,

There was some invalid characters in execution0.log of the report. You can send us the report and we will help you to delete the invalid characters in the execution0.log file.

Hi @duyluong , thanks for the feedback and the offer to fix,
as you mentioned execution0.log I checked the file myself and I see a very long sequence of NUL characters on row 157848 (using Notepad++).
A quick google then showed that I can find these characters by searching for ‘\x00’ with reg ex search and I found that these only occur on that one row - which is where the ‘Start generating HTML report at …’ part begins. I have deleted all occurrences of NUL.

I need to try the fixed report tomorrow to see whether it now appears correctly within KSE but do you have any suggestions as to why this occurred please? It has only occurred in this one suite in the project, which happens to be the largest - we are rerunning the suite again tonight to recheck.
Regards
Dan

Hi @Dan_Bown,

Please send us the execution0.log in private chat if the issue happens again.