java.lang.NullPointerException when using Mobile Recorder

Hi all. I am facing an issue while capturing objects in android device. Can someone help me please

Hi all,

Please use Appium 1.8 in this case. Installation command is:
npm install -g appium@1.8.1.

Appium 1.9 is not supported , that’s why there are errors like that.

1 Like

thank you all
this is very2 helpfull for me
i hope you never bored to help us

Hi @Vinh Nguyen, I think this problem appears again in katalon 5.7.1

No this is a problem using Appium 1.9, just use Appium 1.8.1 and it will be fine for now

Ohh nice

Can you help me for the same problem please,
before, my script runnning as well, and now there is error releted with above


TesCases/GETCRAFT/Register_Client FAILED because (of) (Stack trace: com.kms.katalon.core.exception.StepFailedException: Unable to click on object ‘Object Repository/GETCRAFT/register/link_verifikasi’ (Root cause: java.lang.NullPointerException)
at com.kms.katalon.core.keyword.internal.KeywordMain.stepFailed(KeywordMain.groovy:36)
at com.kms.katalon.core.webui.keyword.internal.WebUIKeywordMain.stepFailed(WebUIKeywordMain.groovy:65)
at com.kms.katalon.core.webui.keyword.internal.WebUIKeywordMain.runKeyword(WebUIKeywordMain.groovy:27)
at com.kms.katalon.core.webui.keyword.builtin.ClickKeyword.execute(ClickKeyword.groovy:67)
at com.kms.katalon.core.keyword.internal.KeywordExecutor.executeKeywordForPlatform(KeywordExecutor.groovy:53)
at com.kms.katalon.core.webui.keyword.WebUiBuiltInKeywords$click$ Source)
at org.codehaus.groovy.runtime.callsite.CallSiteArray.defaultCall(
at com.kms.katalon.core.main.ScriptEngine.runScriptAsRawText(
at com.kms.katalon.core.main.TestCaseExecutor.runScript(
at com.kms.katalon.core.main.TestCaseExecutor.doExecute(
at com.kms.katalon.core.main.TestCaseExecutor.processExecutionPhase(
at com.kms.katalon.core.main.TestCaseExecutor.accessMainPhase(
at com.kms.katalon.core.main.TestCaseExecutor.execute(
at com.kms.katalon.core.main.TestCaseMain.runTestCase(
at com.kms.katalon.core.main.TestCaseMain.runTestCase(
at com.kms.katalon.core.main.TestCaseMain$runTestCase$ Source)
at org.codehaus.groovy.runtime.callsite.CallSiteArray.defaultCall(
at groovy.lang.GroovyShell.runScriptOrMainOrTestOrRunnable(
at groovy.ui.GroovyMain.processOnce(
at groovy.ui.GroovyMain.process(
at groovy.ui.GroovyMain.processArgs(
at groovy.ui.GroovyMain.main(
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(
at sun.reflect.DelegatingMethodAccessorImpl.invoke(
at java.lang.reflect.Method.invoke(

Do you now whats’s the problem?

Actually scenario just click link on body email mailinator

I’m having a similar issue to Angelo Legaspi where Katalon can’t recognize the same object, “android.widget.EditText1 - Password”. I can’t tap on it, I can’t set text, I can’t even use sendKeys after tapping at the position. What can I do to have the test case properly type out the password so I can get my log in, log out script working correctly?

Vinh Nguyen said:

Hi all,

Please use Appium 1.8 in this case. Installation command is:
npm install -g appium@1.8.1.

Appium 1.9 is not supported , that’s why there are errors like that.


I am using Version 1.8 only. But I am getting the same error there also.

Hi All,

I am getting the error java.lang.NullPointerException when I am trying to capture object for my mobile app. Versions are given as below :
Katalon Studio : 5.6.3
Appium : 1.8
Java : 1.8.0

Please find the screenshot below :

Can anybody please assist me in this ? Its very much urgent.

Thanks in advance,


Anyone to help here?

I’m facing the same issue " java.lang.NullPointerException"
When the katalon supported the latest Appium 1.10 atleast ?
Currently I use mojav OS and cannot install the appium with version 1.8.1
What should I do ? please help

Gracias, me ha sido muy útil tu respuesta, saludos.

Hey Any update on this guys? Im getting this error when I use Mobile Recorder.


Im using

Katalon V: 5.10.1

Appium V: 1.10.1java -version

Java V: 1.8.0_181

Hi @rogereyes86,

Katalon Studio 5.10.1 only supports Appium 1.8.1 right now. You can downgrade using npm install -g appium@1.8.1.

Hope this helps,


I am using Katalon 5.10.1 along with Appium 1.8.1 and it has the same error (java.lang.NullPointerException) when executing the recording function in Mobile.
If anyone knows how to get around the problem, help me.

appium.log (47.1 KB)

Hi @Weksley_Santos,

Note that the version of Appium Desktop doesn’t line up with the underlying version of Appium, so you’ll need to get Appium Desktop 1.6.3 (includes Appium 1.8.1) in order to support Katalon Studio 5.10.1:

Try installing that version instead to see if it helps.

– Chris

Hi Soumya
Did you found any solution for your above issue.
As same i am facing

Hello Guys,
I am using Katalon 5.10.1 and appium version 1.8.1 - but unable to capture the objects
Has anyone got a proper solution for this case.

Hi @raghavendrap,

Are you using Appium Desktop 1.8.1 or Appium Server 1.8.1? Unfortunately, the version numbers don’t line up.

If you downloaded an installer to get Appium, it’s probably Appium Desktop, so I recommend getting Appium Desktop 1.6.3:

If you got Appium from npm, then you can verify your version by running appium -v from he command line or use npm install -g appium@1.8.1 to install it.

Check here for some more common troubleshooting tips:

Hope this helps,