Ios-deploy quit unexpectedly or unknown server-side error

**OS **(macOS High Sierra 10.13.3):

Katalon Studio Version (5.3.1)

## Katalon Studio logs:

MacOS (file:///Applications/

Log is empty

## Environment (for Web testing)

Browser (Internet Explorer 11? Firefox 52? Chrome 62?):

## Environment (for Mobile testing)

* Appium version ( 1.7.1 )

* Mobile platform/version under test( iOS 11.2.5 )

* Real device or emulator/simulator ( iPhone 7 (real))

* Xcode version (for iOS) ( Xcode Version 9.2 (9C40b))

* Appium Logs :

[Appium] Welcome to Appium v1.7.1[Appium] Non-default server args:[Appium]   port: 55705[Appium]   loglevel: info[Appium]   chromeDriverPort: 55706[Appium]   tmpDir: /var/folders/rf/8skm47jd0w5b7rrqlykgkbvc0000gp/T//Katalon/Appium/Temp1521126474705[Appium] Appium REST http interface listener started on[HTTP] --> GET /wd/hub/status {}[HTTP] <-- GET /wd/hub/status 200 70 ms - 83 [HTTP] --> GET /wd/hub/status {}[HTTP] <-- GET /wd/hub/status 200 63 ms - 83 [HTTP] --> POST /wd/hub/session {"desiredCapabilities":{"app":"/Users/Dulle/Desktop/Menu.ipa","automationName":"XCUITest","deviceName":"Dulle","fullReset":false,"newCommandTimeout":1800,"noReset":true,"platformName":"iOS","realDeviceLogger":"/Applications/Katalon","udid":"f82827684ad7c422177c86e31f92abea7ae42ca9","waitForAppScript":"true;","wdaLocalPort":55724},"capabilities":{"desiredCapabilities":{"app":"/Users/Dulle/Desktop/Menu.ipa","automationName":"XCUITest","deviceName":"Dulle","fullReset":false,"newCommandTimeout":1800,"noReset":true,"platformName":"iOS","realDeviceLogger":"/Applications/Katalon","udid":"f82827684ad7c422177c86e31f92abea7ae42ca9","waitForAppScript":"true;","wdaLocalPort":55724},"firstMatch":[{"platformName":"ios"}]}}[Appium] Creating new XCUITestDriver (v2.51.1) session[Appium] Capabilities:[Appium]   app: '/Users/Dulle/Desktop/Menu.ipa'[Appium]   automationName: 'XCUITest'[Appium]   deviceName: 'Dulle'[Appium]   fullReset: false[Appium]   newCommandTimeout: 1800[Appium]   noReset: true[Appium]   platformName: 'iOS'[Appium]   realDeviceLogger: '/Applications/Katalon'[Appium]   udid: 'f82827684ad7c422177c86e31f92abea7ae42ca9'[Appium]   waitForAppScript: 'true;'[Appium]   wdaLocalPort: 55724[BaseDriver] Session created with session id: 1938195a-3bcb-475a-a63c-93e8ce524fb4[XCUITest] Determining device to run tests on: udid: 'f82827684ad7c422177c86e31f92abea7ae42ca9', real device: true[BaseDriver] Using local app '/Users/Dulle/Desktop/Menu.ipa'[BaseDriver] Unzipped local app to '/var/folders/rf/8skm47jd0w5b7rrqlykgkbvc0000gp/T/2018215-12892-17tsfp2.oxcu/Payload/'[XCUITest] Setting up real device[XCUITest] Using WDA path: '/usr/local/lib/node_modules/appium/node_modules/appium-xcuitest-driver/WebDriverAgent'[XCUITest] Using WDA agent: '/usr/local/lib/node_modules/appium/node_modules/appium-xcuitest-driver/WebDriverAgent/WebDriverAgent.xcodeproj'[XCUITest] Launching WebDriverAgent on the device[XCUITest] Cannot parse major and minor version numbers from platformVersion "null". Will build for the default platform instead[Xcode] 2018-03-15 16:08:13.390 xcodebuild[12916:1021328] Error Domain=NSCocoaErrorDomain Code=260 "The file "" couldn't be opened because there is no such file." UserInfo={NSFilePath=/Users/Dulle/Library/Developer/Xcode/DerivedData/WebDriverAgent-brdadhpuduowllgivnnvuygpwhzy/Build/Products/Debug-iphoneos/, NSUnderlyingError=0x7fcd99f16200 {Error Domain=NSPOSIXErrorDomain Code=2 "No such file or directory"}}[Xcode] [Xcode] 2018-03-15 16:08:13.390 xcodebuild[12916:1021328] Error Domain=IDETestOperationsObserverErrorDomain Code=6 "Early unexpected exit, operation never finished bootstrapping - no restart will be attempted" UserInfo={NSLocalizedDescription=Early unexpected exit, operation never finished bootstrapping - no restart will be attempted}[Xcode] [Xcode] ** TEST EXECUTE FAILED **[Xcode] [Xcode] [XCUITest] xcodebuild exited with code '65' and signal 'null'[XCUITest] Shutting down sub-processes[XCUITest] Shutting down iproxy process (pid 12913)[HTTP] <-- POST /wd/hub/session 500 24104 ms - 470 

* Application file (.apk/ .ipa) (if possible please provide your application under test file)

## Steps to reproduce -

What I do is click on the Start Mobile Recorder, after which or I get ios-deploy quit unexpectedly or xcodebuild exited with code ‘65’.

Running xcodebuild directly to terminal I get

:dusanh:WebDriverAgent Dulle$ xcodebuild -project WebDriverAgent.xcodeproj -scheme WebDriverAgentRunner -destination 'id=f82827684ad7c422177c86e31f92abea7ae42ca9' -allowProvisioningUpdates=== BUILD TARGET WebDriverAgentLib OF PROJECT WebDriverAgent WITH CONFIGURATION Debug ===
Check dependencies
=== BUILD TARGET WebDriverAgentRunner OF PROJECT WebDriverAgent WITH CONFIGURATION Debug ===
Check dependencies

## Expected Behavior -

It should install webdriverrunner to my physical device

## Actual Behavior -

I get one of the errors : “ios-deploy quit unexpectedly” or “unknown server-side error”.

## Screenshots / Videos

**## Note - **

I have already tried to install webdriverrrunner directly trough xcode, or running command trough terminal, reinstalling appium, ios-deploy and other dependencies.

Also this is my first time trying Katalon studio.

Screen Shot 2018-03-15 at 14.08.00.png

Screen Shot 2018-03-15 at 14.24.44.png


I got the same problem, it’s quite unstable, sometimes it worked but sometime didn’t.

Having the same problem here.

Same problem.

Same problem.

Just an update, i’m able to run app trough the APPIUM just fine, I get this error only with Katalon Studio.

Might work after reinstalling ios-deploy by

$ npm install ios-deploy -g

1 Like

and Nattanon Tharachai said:

Might work after reinstalling ios-deploy by

$ npm install ios-deploy -g

plus manually delete development app and WebDriverAgent app

Hi Nathan, thanks for the post, I already tried all of these things, didn’t help.

I am facing the same issue. Anyone can provide the solution?

I’m having same problem while using iOS mobile. How to solve this?

same problem here! hope Katalon can fix this asap

1 Like

Facing the same problem

Screen Shot 2018-06-06 at 4.07.26 PM.png


I have already tried reinstalling appium, ios-deploy and other dependencies. And also, tried manually delete webdriver agent from the device.

Still getting “ios-deploy quit unexpectedly”

1 Like

Same issue here and always be like this.

I am having the same issue again and again though works fine for sometime. No idea what the issue is with it.

I have the same issue. Sometimes it works, sometimes didn’t.

Please install Appium 1.8 (Binary). KS support Appium 1.8 only.
If you still meet the error after installing Appium 1.8, provide us your .apk/.ipa file for further investigation.