Invalid project description. A Link location must be specified


I set up a git repository with my project and connected it with a git runner to a docker instance.

If I try to start the project I receive the following error:

Start activating online…

Cleaning up workspace

Opening project file: ./test-sfcc.prj    
org.eclipse.core.internal.resources.ResourceException: Invalid project description.
    	at org.eclipse.core.internal.resources.Project.checkDescription(
    	at org.eclipse.core.internal.resources.Project.assertCreateRequirements(
    	at org.eclipse.core.internal.resources.Project.create(
    	at org.eclipse.core.internal.resources.Project.create(
    	at com.kms.katalon.groovy.util.GroovyUtil.initGroovyProjectDescription(
    	at com.kms.katalon.groovy.util.GroovyUtil.initGroovyProject(
    	at com.kms.katalon.controller.ProjectController.openProject(
    	at com.kms.katalon.execution.console.ConsoleMain.getProject(
    	at com.kms.katalon.execution.console.ConsoleMain.findProject(
    	at com.kms.katalon.execution.console.ConsoleMain.launch(
    	at com.kms.katalon.console.application.ConsoleApplicationStarter.start(
    	at com.kms.katalon.application.Application.runConsole(
    	at com.kms.katalon.application.Application.start(
    	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(
    	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(
    	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    	at sun.reflect.NativeMethodAccessorImpl.invoke(
    	at sun.reflect.DelegatingMethodAccessorImpl.invoke(
    	at java.lang.reflect.Method.invoke(
    	at org.eclipse.equinox.launcher.Main.invokeFramework(
    	at org.eclipse.equinox.launcher.Main.basicRun(
    	at org.eclipse.equinox.launcher.Main.main(
    Contains: OK
    Contains: A Link location must be specified.

Tried it also with a simple default project from scratch.
Tried it with and without .project and .classpath files. Also deleted from indexer or caches. And part of gitignore.
Tried it with and without decription in .prj file.

File format changed to txt for forum here.

gitlab-ci.txt (529 Bytes) test-sfcc.txt (966 Bytes)
Any ideas?

gitlab-ci.txt contained this


Here you wrote a relative path. But relative to which base dir? I am puzzled.

On the other hand, the documation writes:

Specify the project location (include .prj file). The absolute path must be used in this case.

The doc seems requiring you to write an absolute path.

Thank you Sir! Got it.