Invalid browser: 'Chrome (headless)' while running in console in Ubuntu server

I am not being able to run katalon testsuite on Ubuntu server console.

Command I am using :
./katalon --args -runMode=console -consoleLog -projectPath="/home/bamboo/shop/shop.prj" -retry=0 -testSuitePath=“Test Suites/SmokeTestSuite” -browserType=“Chrome (headless)”

Exception I get :

com.kms.katalon.execution.exception.ExecutionException: com.kms.katalon.execution.exception.InvalidConsoleArgumentException: Invalid browser: ‘Chrome (headless)’

at com.kms.katalon.execution.console.entity.TestSuiteLauncherOptionParser.getConsoleLauncher(TestSuiteLauncherOptionParser.java:73)

at com.kms.katalon.execution.console.ConsoleExecutor.execute(ConsoleExecutor.java:67)

at com.kms.katalon.execution.console.ConsoleMain.launch(ConsoleMain.java:79)

at com.kms.katalon.console.application.Application.runConsole(Application.java:62)

at com.kms.katalon.core.application.Application.runConsole(Application.java:72)

at com.kms.katalon.core.application.Application.start(Application.java:56)

at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)

at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)

at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)

at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)

at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)

at java.lang.reflect.Method.invoke(Method.java:498)

at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)

at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)

at org.eclipse.equinox.launcher.Main.run(Main.java:1519)

at org.eclipse.equinox.launcher.Main.main(Main.java:1492)

Caused by: com.kms.katalon.execution.exception.InvalidConsoleArgumentException: Invalid browser: ‘Chrome (headless)’

at com.kms.katalon.execution.console.entity.TestSuiteLauncherOptionParser.createRunConfiguration(TestSuiteLauncherOptionParser.java:83)

at com.kms.katalon.execution.console.entity.TestSuiteLauncherOptionParser.getConsoleLauncher(TestSuiteLauncherOptionParser.java:69)

… 18 more

Are you using the latest version of Katalon Studio (5.2)?

@Vinh Nguyen said:
Are you using the latest version of Katalon Studio (5.2)?

Hi Vinh,

Just realised I was using 4.8. I have now updated to 5.2 and I dont see that exception anymore. However now I have different exception which is this:
01-10-2018 05:30:04 PM - [ERROR] - Test Cases/addtobasket FAILED because (of) java.awt.HeadlessException:
No X11 DISPLAY variable was set, but this program performed an operation which requires it.
Any idea on this?

Update : I am trying to run this on non-graphical server.

Thanks

Have you tried some solutions here? https://stackoverflow.com/questions/662421/no-x11-display-variable-what-does-it-mean

@Ana Hong said:
Have you tried some solutions here? https://stackoverflow.com/questions/662421/no-x11-display-variable-what-does-it-mean

Yes, tried that solution but did not work for me.

I get this error after I did export DISPLAY=:0.0
01-11-2018 10:46:31 AM - [ERROR] - Test Cases/addtobasket FAILED because (of) java.awt.AWTError: Can’t connect to X11 window server using ‘:0.0’ as the value of the DISPLAY variable.

I have the same problem with version 5.3
Linux 3f0c06f99bec 4.9.60-linuxkit-aufs #1 SMP Mon Nov 6 16:00:12 UTC 2017 x86_64 GNU/Linux