IE11 Recording not working with version 5.10.1

I have removed and re-installed again. I also restarted PC to ensure no processes were be held onto, checked timestamp on the RecorderExtension.InstallState and still have the same outcome. Any further assistance would be appreciated

@devalex88 - I checked the IE Recording with the plugin 1.1.0 . Tested with IE Version 11.379.17763.0. Here is my finding -

  1. Recording works with few issues -
    Issue 1 - Navigate To Url is not captured. Screenshot attached

  2. XPath details not captured. Only attributes captured.

  3. Run ( all the options ) not working . Screenshot and few logs attached. The error logs are always different.

    2 log files from recording window are attached for referencekatalon-1.txt (16.9 KB)
    katalon-2.txt (10.3 KB)

  4. Playback is working after adding Navigate to URL manually.

1 Like

@ThanhTo @devalex88 - Hi Alex , any ETA by when this issue can be addressed. Also, please also look at the SSL certificated selection window issue. If you help resolve these issue, we will have a good chance of Katalon Studio adoption. And once we decide to adopt, for sure we will go with Enterprise support as per company policy. So please help.

@Prabal_Biswas, we will continue working on IE11 recorder & object spy in 6.1.x releases.

Regarding SSL issue, what will happen when the same website is opened in Chrome?

@devalex88 - Thank you for your prompt response. Regarding SSL - Chrome SSL window is not regular windows alert. During recording we manually select the certificate and continue recording. For playback, we have created a AutoIT component to select the certificate.
The problem with IE during recording is, the Katalon recorder cancels the Alert and certificate doesn’t get selected. If it doesn’t cancel, during recording we can select the certificate manually and during playback add the certificate selection step ( Alert OK). We have tried this by manually creating the test case. So if, you can remove the cancel alert action during recording it will work.

1 Like

@devalex88 @ThanhTo @david.karon - Hi Alex - Update - the IE Recorder with 1.1.0 on corporate network is NOT working. The version of IE is 11.0.900.19267 in our corporate machine, I am facing the same issue as David is facing. The test I carried earlier is on my home machine. All the setting of IE are same at my home and corporate machine i.e - Security, Protected mode and registry setting. Looks like some other service is stopping the recorder to record. I have also checked when recorder is up, jetty server is running at port 50000. But none of the elements are identified nor I get the xpath bar at the top. Is there a way to capture the log and check the issue. Please assist.

@devalex88 - Any update?? Can you assist on how we can trace the problem on corporate machine browser?

@devalex88 - Any update on this please???

Sorry for the late update.

Our QA had tried various combinations of configurations and things worked fine for us :roll_eyes:.

Could you please try again with F12’s Console tab opened and try to capture everything printed there?

We are facing the same problem in 6.1.0 too and this is blocking us to introduce Katalon to our organisation.

1 Like

Sorry to say the all the issues reported earlier still exist in 6.1.2. The selction by XPath - No details are getting captured in IE recording as well as IE Object Spy. I have tried multiple machine with same issue. This is a showstopper and we cannot proceed further. Please atleast help to resolve the XPath selector.

Also,here is the f12 console log. It appears there is is a script error to collect xpath details.

Hi @Prabal_Biswas

This has been a known limitation of Katalon Studio on IE. We’re currently not supporting XPath generator on IE yet, but it is in our plan in the future. Sorry for any inconvenience !

Cheers !

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.