HTML Reports only generates for one of two test suites

Please let us know what you are using Katalon Studio for? Running Test Suites

I have currently applied Katalon Studio in my project

How would your work be affected if this issue has not been resolved?

I can continue my job, resolving this ticket can boost my performance
I can continue my job, but my performance is lower than expected

Operating System

Windows 10 Enterprise

Katalon Studio Version

8.2.0

Katalon Studio logs

  • Windows logs folder: \config.metadata.log

  • macOS logs folder: file:///Applications/Katalon%20Studio.app/Contents/MacOS/config/.metadata/log

Screenshots / Videos

  • Please attach screenshots or videos if necessary to reproduce the issue

Environment (for Web testing):

Browser and Browser version

Environment (for Mobile testing):

  • Appium version

  • Mobile platform/version under test: (for example: iOS 11 or Android 7)

  • Real device or emulator/simulator: (for example: iPhone 6s real or Nexus 6 simulator)

  • Xcode version (for iOS): (for example: Xcode 8 or Xcode 11)

  • Appium Logs: .appium

  • Application file (.apk/.ipa): (if possible)

Steps to reproduce:

Please include an SSCCE (Short, Self Contained, Correct [compilable] example) description http://sscce.org/

If it’s not possible to provide the web page link (for web), please consider creating a reproducible page on https://jsfiddle.net/

Please also provide your test scripts if possible.

Expected Behavior: HTML Report should be generated on every run of a test suite

Actual Behavior: HTML Report are not being generated on every run of a test suite

Hi @jnewman8869,

To support you better, please specify some info below:

  • Did you execute a test suite with retry times or execute a test suite collection with some test suites?
    If it’s hard to describe, please attach the “Execution Information” screenshot of the test suite.
  • Your test suite performed in which type of testing: WebUi, Mobile or API, …?