How to set the request property "WSS-Password Type" to "PasswordText" for soap request

Please help me in setting the property WSS-Password Type to **PasswordText
**I tried with below step
request.addProperty(‘WSS-Password Type’, ConditionType.EQUALS, ‘PasswordText’)
but it is not working

Could you provide the whole script of the request builder and what kind of error you had when executing the case?


I also got the same issue. My code:

import static org.assertj.core.api.Assertions.*

import com.kms.katalon.core.testobject.RequestObject
import com.kms.katalon.core.testobject.ResponseObject
import com.kms.katalon.core.webservice.keyword.WSBuiltInKeywords as WS
import com.kms.katalon.core.webservice.verification.WSResponseManager

import groovy.json.JsonSlurper
import internal.GlobalVariable as GlobalVariable

RequestObject request = WSResponseManager.getInstance().getCurrentRequest()
request.addProperty(“WSS-Password Type”, ConditionType.CONTAINS, “PasswordText”)

ResponseObject response = WSResponseManager.getInstance().getCurrentResponse()

could you add the property into the Header?


I tried to add to the Header but bot I got “400 Bad Request”.

Do anybody have more ideas?