How to handle this error “Unable to click on object” . Cant find the element by path or id …

Hey ,

I tried to find element by xpath/ id … but nothing work. he still can click or find this element .

I will be happy for suggestion

im getting error “Test Cases/Entitlmenet_Error FAILED because (of) Unable to click on object ‘Object Repository/Entitlment_Error/Page_PlainID DEV/span_Entitlement’ (Root cause: com.kms.katalon.core.webui.exception.WebElementNotFoundException: Web element with id: ‘Object Repository/Entitlment_Error/Page_PlainID DEV/span_Entitlement’ located by ‘By.xpath: //span[count(. | id(“plainid-app”)/div/div[1]/div[1]/div/div[2]/div[5]/div[1]/span[2] //[@id=“plainid-app”]/div/div[1]/div[1]/div/div[2]/div[5]/div[1]/span[2]) = count(id(“plainid-app”)/div/div[1]/div[1]/div/div[2]/div[5]/div[1]/span[2] //[@id=“plainid-app”]/div/div[1]/div[1]/div/div[2]/div[5]/div[1]/span[2])][count(. | //[@class = ‘menu-page-name’]) = count(//[@class = ‘menu-page-name’])]’ not found)”

Unable to click on object ‘Object Repository/Page_PlainID DEV/span_Entitlement’ (Root cause: com.kms.katalon.core.webui.exception.WebElementNotFoundException: Web element with id: ‘Object Repository/Page_PlainID DEV/span_Entitlement’ located by ‘By.xpath: //*[@id=\“plainid-app\”]/div/div[1]/div[1]/div/div[2]/div[5]/div[1]/span[2]’ not found)

Hey,

i tried this solution its still doesn’t work

he can find and click on elements

Hi guys, I have problem with similiar issue.

I found message error like this:
Unable to click on object ‘Object Repository/Staging Mbiz.co.id/Solusi Total Pengadaan Online/img_img-loaded’ (Root cause: org.openqa.selenium.WebDriverException: unknown error: Element is not clickable at point (227, 551). Other element would receive the click:


  • (Session info: chrome=63.0.3239.132)
    (Driver info: chromedriver=2.35.528161 (5b82f2d2aae0ca24b877009200ced9065a772e73),platform=Windows NT 10.0.16299 x86_64) (WARNING: The server did not provide any stacktrace information)
    Command duration or timeout: 0 milliseconds
    Build info: version: ‘3.7.1’, revision: ‘8a0099a’, time: ‘2017-11-06T21:07:36.161Z’
    System info: host: ‘GEZZYANNI’, ip: ‘10.200.16.38’, os.name: ‘Windows 10’, os.arch: ‘amd64’, os.version: ‘10.0’, java.version: ‘1.8.0_102’
    Driver info: com.kms.katalon.selenium.driver.CChromeDriver
    Capabilities {acceptInsecureCerts: false, acceptSslCerts: false, applicationCacheEnabled: false, browserConnectionEnabled: false, browserName: chrome, chrome: {chromedriverVersion: 2.35.528161 (5b82f2d2aae0ca…, userDataDir: C:\Users\USERBA~1\AppData\L…}, cssSelectorsEnabled: true, databaseEnabled: false, handlesAlerts: true, hasTouchScreen: false, javascriptEnabled: true, locationContextEnabled: true, mobileEmulationEnabled: false, nativeEvents: true, networkConnectionEnabled: false, pageLoadStrategy: normal, platform: XP, platformName: XP, rotatable: false, setWindowRect: true, takesHeapSnapshot: true, takesScreenshot: true, unexpectedAlertBehaviour: , unhandledPromptBehavior: , version: 63.0.3239.132, webStorageEnabled: true}
    Session ID: 8a433e994605e08e802f576ee8799243)

    Please help me if you know.

    Try using WebUI.waitForElementVisible

    I was used WebUI.waitForElementVisible but still failed. What should I do for this error?

    Test Cases/TCCreateRFQ FAILED because (of) groovy.lang.MissingMethodException: No signature of method: static com.kms.katalon.core.webui.keyword.WebUiBuiltInKeywords.waitForElementVisible() is applicable for argument types: (com.kms.katalon.core.testobject.TestObject) values: [TestObject - ‘Object Repository/Staging Mbiz.co.id/Solusi Total Pengadaan Online/img_img-loaded’]
    Possible solutions: waitForElementVisible(com.kms.katalon.core.testobject.TestObject, int), waitForElementVisible(com.kms.katalon.core.testobject.TestObject, int, com.kms.katalon.core.model.FailureHandling), waitForElementNotVisible(com.kms.katalon.core.testobject.TestObject, int), waitForElementNotVisible(com.kms.katalon.core.testobject.TestObject, int, com.kms.katalon.core.model.FailureHandling)

    I’m getting the same error when attempting to click a button using xpath. What is the correct syntax for clicking a button via syntax? Below is what I currently have. It works when using Spy Web

    WebUI.click(findTestObject(xpath="//input[@value = '200 ']/following-sibling::input[@value=‘Gift’]"))