How can I solve the following error?

Hi,help me to solve this error
=============== ROOT CAUSE =====================

Caused by: org.openqa.selenium.ElementClickInterceptedException: element click intercepted: Element is not clickable at point (1010, 791). Other element would receive the click:

For trouble shooting, please visit:


08-04-2023 12:16:41 AM Test Cases/iphone-postnord

Elapsed time: 41.602s

Test Cases/iphone-postnord FAILED.


com.kms.katalon.core.exception.StepFailedException: Unable to click on object ‘Object Repository/Page_Apple iphone13 - Se pris och kp med ab_65c9c7/input_Surfa i 30 extra lnder_mui-5’

at com.kms.katalon.core.webui.keyword.internal.WebUIKeywordMain.stepFailed(WebUIKeywordMain.groovy:64)

at com.kms.katalon.core.webui.keyword.internal.WebUIKeywordMain.runKeyword(WebUIKeywordMain.groovy:26)


at com.kms.katalon.core.webui.keyword.builtin.ClickKeyword.execute(ClickKeyword.groovy:40)

at com.kms.katalon.core.keyword.internal.KeywordExecutor.executeKeywordForPlatform(KeywordExecutor.groovy:74)


at com.kms.katalon.core.webui.keyword.WebUiBuiltInKeywords$click$ Source)



at com.kms.katalon.core.main.ScriptEngine.runScriptAsRawText(

at com.kms.katalon.core.main.TestCaseExecutor.runScript(

at com.kms.katalon.core.main.TestCaseExecutor.doExecute(

at com.kms.katalon.core.main.TestCaseExecutor.processExecutionPhase(

at com.kms.katalon.core.main.TestCaseExecutor.accessMainPhase(

at com.kms.katalon.core.main.TestCaseExecutor.execute(

at com.kms.katalon.core.main.TestCaseMain.runTestCase(

at com.kms.katalon.core.main.TestCaseMain.runTestCase(

at com.kms.katalon.core.main.TestCaseMain$runTestCase$ Source)


Caused by: org.openqa.selenium.ElementClickInterceptedException: element click intercepted: Element is not clickable at point (1010, 791). Other element would receive the click:

(Session info: chrome=115.0.5790.114)

Build info: version: ‘3.141.59’, revision: ‘e82be7d358’, time: ‘2018-11-14T08:25:53’

System info: host: ‘MAC-C02YV0W7LVDR’, ip: ‘fe80:0:0:0:10c9:fc53:1f66:c0ee%en0’, ‘Mac OS X’, os.arch: ‘x86_64’, os.version: ‘10.16’, java.version: ‘1.8.0_275’

Driver info: com.kms.katalon.selenium.driver.CChromeDriver

Capabilities {acceptInsecureCerts: false, browserName: chrome, browserVersion: 115.0.5790.114, chrome: {chromedriverVersion: 114.0.5735.90 (386bc09e8f4f…, userDataDir: /var/folders/yw/7_c2y4gj6ld…}, goog:chromeOptions: {debuggerAddress: localhost:55858}, javascriptEnabled: true, networkConnectionEnabled: false, pageLoadStrategy: normal, platform: MAC, platformName: MAC, proxy: Proxy(), setWindowRect: true, strictFileInteractability: false, timeouts: {implicit: 0, pageLoad: 300000, script: 30000}, unhandledPromptBehavior: dismiss and notify, webauthn:extension:credBlob: true, webauthn:extension:largeBlob: true, webauthn:extension:minPinLength: true, webauthn:extension:prf: true, webauthn:virtualAuthenticators: true}

Session ID: 7c27eead5da4fa0a32cbdd8395ddcd51

at org.openqa.selenium.remote.http.W3CHttpResponseCodec.createException(

at org.openqa.selenium.remote.http.W3CHttpResponseCodec.decode(

at org.openqa.selenium.remote.http.W3CHttpResponseCodec.decode(

at org.openqa.selenium.remote.HttpCommandExecutor.execute(

at org.openqa.selenium.remote.service.DriverCommandExecutor.execute(

at org.openqa.selenium.remote.RemoteWebDriver.execute(

at com.kms.katalon.selenium.driver.CChromeDriver.execute(

at org.openqa.selenium.remote.RemoteWebElement.execute(



at com.sun.proxy.$ Source)


at org.openqa.selenium.WebElement$ Source)

at com.kms.katalon.core.webui.keyword.builtin.ClickKeyword.clickUntilSuccessWithTimeout(ClickKeyword.groovy:81)

at com.kms.katalon.core.webui.keyword.builtin.ClickKeyword.clickUntilSuccessWithTimeout(ClickKeyword.groovy)

at com.kms.katalon.core.webui.keyword.builtin.ClickKeyword$_click_closure1.doCall(ClickKeyword.groovy:67)

at com.kms.katalon.core.webui.keyword.builtin.ClickKeyword$

at com.kms.katalon.core.webui.keyword.internal.WebUIKeywordMain.runKeyword(WebUIKeywordMain.groovy:20)

… 17 more

It means one or other of the following:

  1. something else is present in front of the element you are trying to click

  2. the thing you’re trying to click is not present when you try to click it

  3. A bunch of other possibilities (including the two above) usually solved by adding a delay before you attempt the click.

Start reading here:

It would only be a slight exaggeration to tell you there are a thousand similar requests for help already answered on this forum. Please use search in future. Look how easy it is…

1 Like

I tried various methods like wait for element clickable, scroll ,wait for element visible ,enchanced click,delay,java argument as well. I’m still getting an same error.please help me out to solve this issue .The test passes while I scroll the webpage by manually .it clicks that element .

Did you try…

yes,I tried

I’m still getting this error.
=============== ROOT CAUSE =====================
Caused by: org.openqa.selenium.ElementClickInterceptedException: element click intercepted: Element is not clickable at point (1156, 58). Other element would receive the click:

This is like pulling teeth.

I know what the error is. And when I said “Did you try…” I expected more than “Yes, I tried”. How about sharing what happened?

You understand I’m working blind here? You understand I’m not ChatGPT, right?
If we’re waiting for me to stumble on the right question to get the vital piece of info that leads to the correct answer, we could be here a VERY LONG TIME.

And trust me, if you have a webpage that has HTML elements that cannot be clicked using automation, congratulations. That’s the first one. Ever. Seriously.

Last question: Did you try clicking the element using JavaScript in the browser console?

sorry,I’m completely new beginner in katalon studio.Thank you so much for your time .I tried using executeJavaScript it works.