How can i open Chrome with –disable-web-security –user-data-dir=c:\my\data

So i am trying to open a test case using the chrome browser, but for my manual tests i need to use a browser shortcut using " --disable-web-security --user-data-dir=c:\my\data" at the end on the line, in properties.

How can this be done using Katalon? I tried setting my Settings- execution - default -= webUI - chrome - with the given value, but no luck.

Also tried to add a web browser in Katalon preferences, with the browser location pointing to a shortcut on my desktop, that has the --disable… but that browser does not show up in my Run option.

And No, i cannot “Disable web security” for the main chrome browser.

I somehow managed to leave open that browser and select “active browser” and it seems to work, after a few tries, that window will be selected. So taht’s a temporary solution. Thanks!

Hi there,

Those settings are only applied to execution. Record or Spy browsers haven’t support passing these settings yet.

Thanks

ok, so it works, but: How can i make my Spy Web also open up in the disabled web security chrome?

Awesome! it work! thanks a million :smiley:

Hi there,

Please try adding settings as showing in this picture: http://prntscr.com/fbfs7z

Thanks

Hi, Can we use this same method directly on firefox browser ?