Heap Memory Issue when try to execute Testsuite collection

Hi team,
When i am trying to execute suite collection i am getting Heap memory issue and some times katalon is getting stuck.

I have tried following :

  1. Updated kataon to latest version(7.2.6)
  2. Increase xms and xmx values

OS:windows(64-bit version)


Please let me know if you guys have any solution for this particular issue.


decrease your values
-Xms4096m and -Xmx4096m
and try

You can also monitor the heap:


This will produce a heap status monitor in the KS status bar:


You can click the trashcan button to help release memory back to the pool.

Also, remember to clear out old runtime logs:


1 Like

Hi @Timo_Kuisma1 and @Russ_Thomas,

Thanks for the reply.
I tried both the ways you guys have suggested but I am facing the same issue.
I observed that the memory is crossing the limit that I have mention in Execution file.
Are there any other ways to resolve this.

Katalon does not start if i put -XmX2048. Is there any other way?

Can this be done programmatically?

yes it does, at least for me:

1 Like

Your -XmX2048 is wrongly formatted.

  • -XmX should rather be -Xmx
  • 2048 should rather be 2048m

For the correct format, have a look at the official document of java command at:

-Xmx size
Specifies the maximum size (in bytes) of the heap. This value must be a multiple of 1024 and greater than 2 MB. Append the letter k or K to indicate kilobytes, m or M to indicate megabytes, or g or G to indicate gigabytes. The default value is chosen at runtime based on system configuration. For server deployments, -Xms and -Xmx are often set to the same value. The following examples show how to set the maximum allowed size of allocated memory to 80 MB using various units: