"Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged" if not running with root


I am facing an issue, I don’t understand
I can test suite with Katalon Runtime engine locally by creating a docker container and it’s working perfectly.
But when I try to integrate with Jenkins I got error. I have Jenkins running in a docker container. What I want to do is to create and run the Katalon docker container inside of the Jenkins container.

It’s working if I run the Katalon docker image as root. But I want to run it as Jenkins user. When doing that I got the error:

Katalon workspace folder is set to default location: /tmp/session-05ea8934
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.

and the jenkins job is stuck there and I have to kill the job.

Anyone is facing the same issue as mine? If yes, could you share how you fix the problem?

Many thanks

Hi @phung.nguyen

Please refer to this manual https://docs.katalon.com/katalon-studio/docs/jenkins-pipeline-docker.html and try again to see if you can succeed.

Happy Testing

Hi @Jass,
Thanks for your link. We set differently the step in the Jenkins file.

Stage Run Test
  stage('Run Test') {
    steps {
      withCredentials([string(credentialsId: 'katalon-api-key', variable: 'KATALON_API_KEY')) {
        withDockerContainer(image: ""katalonstudio/katalon:latest"", args: "--rm -u=root") {

          // running Katalon test suites
          sh "katalonc.sh -projectPath=${WORKSPACE} \
                          -browserType="Chrome" \
						  -retry=0 \
						  -statusDelay=15 \
						  -testSuiteCollectionPath="test_suite_collection_test" \
						  -apiKey=\"${KATALON_API_KEY}\" "

The Jenkins pipeline is working but only when I run the Katalon container as root. I prefer to see it working when running with Jenkins user. I still don’t understand why…