Getting Error while integrating webdriver scripts

I am getting error while integrating the webdriver scripts in katalon studio

groovy.lang.MissingPropertyException: No such property: Testing for class: Script1631511119520
at com.kms.katalon.core.main.ScriptEngine.runScriptAsRawText(
at com.kms.katalon.core.main.TestCaseExecutor.runScript(
at com.kms.katalon.core.main.TestCaseExecutor.doExecute(
at com.kms.katalon.core.main.TestCaseExecutor.processExecutionPhase(
at com.kms.katalon.core.main.TestCaseExecutor.accessMainPhase(
at com.kms.katalon.core.main.TestCaseExecutor.execute(
at com.kms.katalon.core.main.TestCaseMain.runTestCase(
at com.kms.katalon.core.main.TestCaseMain.runTestCase(
at com.kms.katalon.core.main.TestCaseMain$runTestCase$ Source)

I would say you have the word, Testing, standing on a line by itself without quotes or being commented out, like:

Instead of like:
// Testing



1 Like

using in this way


Notice that “Testing” is underlined. In KS, that means it is not defined beforehand. I think you need to tell us what you were trying to do? Note: obviously your statement is currently not correct.

I have existing selenium scripts …want to migrate my project at katalon…my scripts visible under groovy folder…but i am unable to call…

Then i have tried with sample but getting same error

You probably need a Community Modulator, however, did you try to copy and paste your Selenium script into Katalon Studio and then run it? My understanding is that KS will run Selenium scripts.

@Russ_Thomas, @kazurayam Do you know if the OP can run Selenium scripts directly from KS or is there some import process?

Dunno. @Brandon_Hein’s the guy you want here.

You can absolutely run pure Selenium scripts in KS (in fact, that’s ultimately what KS is doing behind the scenes when you call WebUI keywords), however you’ll need to do some tinkering to get your WebDriver instance set up the way you want.

Regarding the specific error in the OP, you are trying to call a class that you haven’t imported yet. Simple as that…

Please tell us the concrete full path of the source file of your “Test” class.

It seems that you located the source code into some wrong place and Katalon Studio can not recognise it.

My selenium code file is under groovy>>Eaisvar folder (Lets say “”) and I want to execute that class code file from home but getting error while execution.
Please help me to understand the process to integrate selenium Project into Katalon studio.

Your test case script (is it named “home”?) should have an import statement for Eaisvar.Testing class

import Eaisvar.Testing

List testClasses = [Testing.class]

You have this line in the Testing.class:

System.getProperty("user.dir") + "\\Include\\...."

When you run this in Katalon Studio GUI, it will be OK. But when you run this in Katalon Runtime Engine in command line, it will fail.

As you may be aware of, System.getProperty("user.dir") regurns what is called “current directory” for a OS user.

When you are in Katalon Studio GUI, the current directory will be equal to the Katalon project directory.

But when you execute a test in Katalon Runtime Engine, the current directory will be (unless intentionally tailored) equal to the directory where katalonc.exe is found. So that a call to System.getProperty("user.dir") + "\\Include\\... does not make sense.

thanks for your help

Hi excel data is coming like this for integrated project can u help please

What is your question? I don’t understand the above post at all.

Hi I have migrated my selenium project into Katalon.
when migrated Test Date excel file formatting changed and its coming in the above format… So I need help how it will be in normal format so my data should be in understandable form

Do you want to open a *.xlsx file using Microsoft Excel in Katalon Studio?

No, it is not supported.

You need to open a *.xlsx file in Windows Explorer.

how can these type errors be removed?

Learn how to by reading this:

Where do you get the required jars? I do not know. You should be aware of it.

Is it this?