Failed run the ci/cd on github action

Has anyone ever had an issue like this? So when I tried the ci/cd on GitHub action the test case didn’t work or run and got failed.

This is what my yml configuration looks like:

name: CI Automation Testing
on:
  push:
    branches: [ master ]
  pull_request:
    branches: [ master ]
jobs:
  build:
    runs-on: windows-latest
    steps:
    - name: Checkout
      uses: actions/checkout@v3
    - name: Katalon Studio Github Action
      uses: katalon-studio/katalon-studio-github-action@v3.0
      with:
          version: '7.5.5'
          projectPath: '${{ github.workspace }}'
          args: '-noSplash -retry=0 -browserType=Chrome -statusDelay=15 -testSuitePath="Test Suites/Authentication" -apiKey= ${{ secrets.KATALON_API_KEY }} --config -webui.autoUpdateDrivers=true'

This only happens on ci/cd but when I run it locally on my machine it’s normal.

1 Like

Hi there,

Thank you very much for your topic. Please note that it may take a little while before a member of our community or from Katalon team responds to you.

Thanks!

Hi @adnanerlansyah403 ,

Welcome to our community. Which Katalon version and ChromeDriver version are you using?

Inside Github action, chrome version is 114. check your local machine chrome driver version, it might be latest. Can you try to use latest version inside github image

1 Like

How can I update the latest version of chrome inside github image sir?

I see you using KRE with version 7.5.5, could you use the latest version instead?With KRE version previous 8.x, the latest ChromeDriver only get 114.

3 Likes

I think it’s still the same sir, I’ve changed the version of Katalon to 8.6.8 on my YML configuration.



Could you please use the latest version of 8.6.9?Version 8.6.9 is the latest of version 8.

@adnanerlansyah403 - Downgrade your local chrome browser as 114 or use updated as mentioned by @phong.nguyen

Oh, oke sir, the issue is already fixed but now comes the new issue. But I think this is because I didn’t run the test on headless mode, right? how can I setup my browser to run on mode headless while running it on ci/cd?

Because the tests are normal when I run on my local machine.

1 Like

The error is about Element not found, specific for css selector .modal button.close, you could check it in your local and correct the its locator. This issue doesn’t related with whether headless or not.
By the way, if you want to run with Chrome headless, simple add a param like this: -browserType=“Chrome (headless)”

2 Likes

fix your locator for close button modal

1 Like

It’s working perfectly when I run it on my local machine

I think it’s working perfectly sir while I’m running it on my local machine, why do you expect it from my selector or locator?

How can I fix this sir?

Hi,

Please consider adding some waits because there might be some loading issues with the online environment that the local environment does not face. You can read more over here:

2 Likes