Facing java.lang.Error: Unresolved compilation problem: *in Katalon version 8.6.6 while getting sheet details using Excel keywords

1 Like

I think this one line of code is wrong.

ExcelWorksheets.getExcelSheet() implements getExcelSheet() method, which returns org.apache.poi.ss.usermodel.Sheet.

But the Sheet object does not implements getValue() method. Therefore this line would not compile.

Also I have a doubt about the last fragment:

       Report", 1), 0)

I think ,0) is just invalid.


the above is the exact line to assign value to the variable sheet01

since i used the Excel keywords katalon plugin from the katalon plugin store no the apache POI for this code.

this line of code will read the value that is stored in my Excel file using the data files in (Katalon)
the last .getValue(“column Name”,row number)


It seems that you changed your code from the original to a new one.

Do you still have “java.lang.Error: Unresolved compilation problem: *in Katalon…” ?


still i’m getting the same error

this is the code returned in my log viewer

and this is the code available in my test cases script tab.

it worked fine in Katalon 7.7.2 since the Chrome driver issue I updated to Katalon version 8.6.6 then I’m getting this issue.

not only this some of the variable name’s cases(lowercase to uppercase the one under the profile’s manual view is different thean than the one in </> script view) also changed (Global variables) under my profile

i even reloaded my plugins


I can not guess what happend to you. I have no idea.

If you remove the black paints that hides some string values so that we can read them, then it may give us better idea. These black paints disturbes others to guess at all.

1 Like

Thanks for the suggestion
i got the solution for the issue

it should be in this format
but after migrating katalon from 7.7.2 to 8.6.6
it converts the code from the above to this Don’t know this is a feature which tampering the code/script

after removing the below method scripts are working fine.


@ Elly_Tran
I used Katalon studio 7.7.2 due to the chrome driver change I switched to 8.6.6
I’m facing the following issue

when I open my project in Katalon studio 7.7.2 the script view shows the below code

when I open the same project file in Katalon studio 8.6.6 the script view shows the below code by default new version adds the ExcelKeyword.getExcelSheet() method to the existing code and it fails the scripts.

please use the following code to reproduce the same

  1. create a project in 7.7.2 and save it in a test case

  2. open the project file in 8.6.6

sheet01=findTestData(path of Data File in data filesfolder).getValue(columName’,rowNumber )