Error when tests start - can't open Browser


#1

When I run my tests, the initial ‘Open Browser’ fails with the following:

Unable to open browser with url: ‘’

This was working a couple of weeks ago, but now I can’t run my tests.


#2

More more info on this issue, I recently started running apache locally for my project and I get this Root Cause for the ‘Open Browser’ command failing:

(Root cause: org.openqa.selenium.WebDriverException: org.apache.http.conn.HttpHostConnectException: Connect to localhost:39019 [localhost/0:0:0:0:0:0:0:1] failed: Connection refused

Driver info: driver.version: CGeckoDriver)


#3

I’m getting the same error since a few weeks:

2018-11-19 09:55:11 - [TEST_STEP][FAILED] - openBrowser: Unable to open browser with url: 'xxxxx'
(Root cause: org.openqa.selenium.WebDriverException: permission deniedBuild info: version: '3.7.1', revision: '8a0099a', time: '2017-11-06T21:07:36.161Z'System info: host: 'XXXX', ip: 'XX.XX.XX.XX', os.name: 'Windows Server 2012 R2', os.arch: 'amd64', os.version: '6.3', java.version: '1.8.0_181'Driver info: driver.version: CGeckoDriverremote stacktrace: )

I’m using Katalon remotly via command line. I don’t know if this is part of the problem


#4

Hi, did you manage how to fix this problem? , cos I’m experiencing the same executing in katalon with or without jenkins,

Thanks