Error after running a webrecord


I was trying out the wb recording utility. I have recorded a web page, later i tried to run it an encountered the following error
click(findTestObject(“Object Repository/DMS2/Page_eSDMS - testuser/a_Logout”)) FAILED.
com.kms.katalon.core.exception.StepFailedException: Unable to click on object ‘Object Repository/DMS2/Page_eSDMS - testuser/a_Logout’ (Root cause: org.openqa.selenium.WebDriverException: unknown error: Element is not clickable at point (761, 40). Other element would receive the click:


the object mentioned in the error is already created as shown in pic.

can somebody help me with this error?

This error means exactly what it says – if the driver were to issue the click, something else would receive the click, not the a_Logout element. This usually means something on your page is getting in the way but without being able to see your page it’s not possible to say what that something is.

Things you can try:

Before the click, wait for a short time until the a_Logout element is clickable:

WebUI.waitForElementClickable(findTestObject('Object Repository/DMS2/Page_eSDMS - testuser/a_Logout'), 20)

In future, it might help if you post more/better info about your problem/page:

Thanks, that worked!!