Data Files path not working


#1

I have a test file. When I put it folder C:\Users\XCHEN28\Desktop\CMS test\02. Auto Test\0-Test Data, the test suit could not be executed:
image

However, when I put it in C:/Support, it works.


#2

Now its very hard for us to give you a solution for an issue like this when we cant access your machine as we arent aware of your access levels for different folders. Now there should be no reason why this is failing, depending on the fact that all your paths for the test data are set up correctly that is. Are there any security feautres on the folder that the file is saved in?

What i will say is please check that the folder path is correct in test data and in the test suite.

PS - If you can change from C:\Users\XCHEN28\Desktop\CMS test\02. Auto Test\0-Test Data to C:/Support without having to change anything in katalon then the location is incorrect and will never work for C:\Users\XCHEN28\Desktop\CMS test\02. Auto Test\0-Test location.

Could you also send a screenshot of the binding data for the test case in the suite and a screenshot of the test data itself.


#3

Harry has a point on this…

But there’s another strange thing here, look at the error message. . . . The reason is invalid column, it means path works. If it is about the path then it should return an exception of FileNotFoundException.

For Chen, try to double check your code… or send some snippet here. . .


#4

Hi… Thanks for all your comments. I did not use script to include the excel into my testing. I used the KS feature to bind Data Files.

Refer to your comments, I tried the binding data again today, it then worked :sweat: