Content-Type of the API request updates automatically upon change in request body

I want to keep the Content-Type of the request as ‘text/xml’.

When I update the HTTP Body and save the request, Content-Type is changed automatically to ‘application/json’.

Not able to find the fix for this. I even tried setting the content type using the global variable. That gets updated too after changing the request body.

I am facing a similar issue.
I have written in Content-Type application/query+json. Saved. It is ok.
Now I do a change in the Body of the Http request => the Content-type switched back to default value text/plain.
Can you fix this please?

Thanks
Version 7.0.10 Mac

Hi @allied.solutions, @vanhuffelen.pascal,
We will investigate the issue and get you noticed soon.
Regards.

Hi @allied.solutions, @vanhuffelen.pascal,
We have scheduled a fix for this issue and it will be available in version 7.2.5.

1 Like

Hi,
I just tested this on my mac. Version 7.2.5.
And I am still facing the same issue.
Content-type : application/query+json
When I modify the body and check the Content-type, it will be changed to text/plain.

Can you help me? @huynguyen

Thanks

Hi @vanhuffelen.pascal

Have you unchecked the option “Auto update HTTP Header”. It should be visible in the HTTP body tab.

1 Like

Alright!
That did the trick. But I need to uncheck the box then SAVE. Then I can modify the body.
If uncheck the box and modify the body directly, it will still change back to text/plain.

Thanks for the fix guys! :slight_smile:

2 Likes

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.