Connecting to Oracle DB using TCPS protocol

Hi ,

I am using Katalon 8.3.0 trial version
Trying to connect to an Oracle db using TCPS protocol. But always getting the error: SQL Exception: IO Error: Connection reset

Using Toad we are connected to the db and able to run all queries on the db tables.
I am using the details as in the tnsname.ora file which is used to connect to db as given below:-

G4_19C=(DESCRIPTION=(ADDRESS=(PROTOCOL=TCPS)(HOST=xxxxx)(PORT=1523))(CONNECT_DATA=(SERVER=DEDICATED)(SERVICE_NAME=xxxxx))(SECURITY=(SSL_SERVER_CERT_DN=“xxxxx,OU=IEO,O=xxxxx,L=Round Rock,ST=Texas,C=US”)(MY_WALLET_DIRECTORY=C:\app\client\xxxxxxxx\product\19.0.0\client_1\network\admin\affinity_client_wallet\client_wallet)))

Tried including all details in connection string , but still getting error.
Is it the issue with the Licensing? Or Katalon required any firewall changes to be made to connect to via VPN?

Let me know if you need more details

Did you get your issue solved? I faced the same and after several attempts I was able to make it work.