Can't scroll down

I’ve tried to scroll the page using the keyword ‘scroll to element’ or ‘scroll to position’. But nothing seem to work. I just want to scroll down the page from top to bottom. Anyone got an idea to solve this? Thank You

any error?

No…Just failure. This time I try to scroll down and click one of the element. Should I use scroll to element or scroll to position? Before this I tried both method but it didn’t work out

ok, can you post that failure?

Its okay…I just used the scroll to element and pick the object. Its not like what i wanted but still get the job done. Thank You Andrej for your helped. I really appreciate it

i did nothing to be honest, so you are welcome :slight_smile:

Maybe you can help me with this problem: WebUI.maximize Window() doesn’t work. The page suddenly didn’t maximize window and get stuck as it can select the object.

import static com.kms.katalon.core.checkpoint.CheckpointFactory.findCheckpoint

import static com.kms.katalon.core.testcase.TestCaseFactory.findTestCase

import static com.kms.katalon.core.testdata.TestDataFactory.findTestData

import static com.kms.katalon.core.testobject.ObjectRepository.findTestObject

import com.kms.katalon.core.checkpoint.Checkpoint as Checkpoint

import com.kms.katalon.core.checkpoint.CheckpointFactory as CheckpointFactory

import as MobileBuiltInKeywords

import as Mobile

import com.kms.katalon.core.model.FailureHandling as FailureHandling

import com.kms.katalon.core.testcase.TestCase as TestCase

import com.kms.katalon.core.testcase.TestCaseFactory as TestCaseFactory

import com.kms.katalon.core.testdata.TestData as TestData

import com.kms.katalon.core.testdata.TestDataFactory as TestDataFactory

import com.kms.katalon.core.testobject.ObjectRepository as ObjectRepository

import com.kms.katalon.core.testobject.TestObject as TestObject

import com.kms.katalon.core.webservice.keyword.WSBuiltInKeywords as WSBuiltInKeywords

import com.kms.katalon.core.webservice.keyword.WSBuiltInKeywords as WS

import com.kms.katalon.core.webui.keyword.WebUiBuiltInKeywords as WebUiBuiltInKeywords

import com.kms.katalon.core.webui.keyword.WebUiBuiltInKeywords as WebUI

import internal.GlobalVariable as GlobalVariable

import org.openqa.selenium.Keys as Keys


‘Slow down process when using playback’


WebUI.setText(findTestObject(‘Page_Reporting Management System/input_txtUserID’), ‘secuser2’)

‘Slow down process when using playback’

WebUI.delay(3)‘Page_Reporting Management System/button_Login’))

‘Accept alert after login’


‘Slow down process when using playback’


'Used spy-web because can\‘t detect drop-down menu’‘Spy-web/a_SYNCHRONIZE’))

WebUI.waitForElementClickable(findTestObject(‘Page_INReport/a_Country Codes’), 5)‘Page_INReport/a_Country Codes’))

WebUI.waitForElementClickable(findTestObject(‘Page_INReport/a_CO’), 5)

WebUI.scrollToElement(findTestObject(‘Page_INReport/a_CO’), 3)

WebUI.waitForElementClickable(findTestObject(‘Page_INReport/a_CO’), 5)‘Page_INReport/a_CO’))

WebUI.waitForElementClickable(findTestObject(‘Page_INReport/a_Administration’), 5)‘Page_INReport/a_Administration’))

WebUI.waitForElementClickable(findTestObject(‘Spy-web/a_ACCESS CONTROL’), 5)

'Used spy-web because can\‘t detect drop-down menu’‘Spy-web/a_ACCESS CONTROL’))‘Page_INReport/a_User Profile’))

WebUI.setText(findTestObject(‘Page_INReport/input_UPID’), ‘secuser2’)‘Page_INReport/button_Search’))


WebUI.scrollToElement(findTestObject(‘Page_INReport/input_cmdBack’), 3)

'Used spy-web because can\‘t detect drop-down menu’‘Spy-web/a_secuser2’))‘Page_INReport/a_Sign out’))‘Page_INReport/button_Confirm’))


did you try to move maxWindow directly after openWindow?

No…how to ‘maxWindow’?

I think you can try:

and so on…

1 Like

I’ve tried to scroll the page using the keyword ‘scroll to element’.But its not working.Please help me to resolve this one.

Scroll to Element is not Working in Katalon Studio

Can you send the image ?I want to see the interface that have scrolling function?

I’ve found that if I “run from here” in a test case, starting with the scroll to step, that it works as expected. However, if I incorporate a scroll to element/position step in a test case and run it from the top or as part of a test suite, the scroll to step passes, but actually “does nothing”. I’ve added wait for element clickable and verify element clickable, which both pass. However, clicking the element does not actually work (element not intractable). Verify element in viewport fails, so it seems that the failure to scroll (even though Katalon reports the scroll as a success) is causing the element to not be in the viewport (even though Katalon reports the element as clickable). Sometimes, if I add a several second delay before and after the scroll to step, it will work, but not always.

Does anyone have a solid solution for this issue? I don’t want to add a bunch of delays to my tests if I can avoid it.

Hi @potato,

Any luck on this issue?
I have the same issue now

I don’t have a clean solution, but some combination of scroll to position 99999;99999 and scroll to element, plus delays (2 seconds) after each seems to work most of the time.

In one case I did find that the issue was the element I was trying to click actually had two matches for my selector. So I think in that case, Katalon was confused about which element I was trying to scroll to/click. Once I updated the selector to get just the one element I wanted, it did work better.

I was having the same issue, but realized that the element which i was trying to click had more than one matches. then updated the selector and it worked.