Can't package my-first-katalon-plugin

I have download the [katalon-studio-sample-plugin] the other day, and it worked well in my eclipse.
but since yesterday I can’t package my project. here are the error:

[ Failed to execute goal on project my-first-katalon-plugin: Could not resolve dependencies for project com.mycomany.plugin:my-first-katalon-plugin:bundle:1.0.0: Failed to collect dependencies at org.eclipse.platform:org.eclipse.e4.core.contexts:jar:1.5.1 -> org.eclipse.platform:org.eclipse.e4.core.di:jar:1.7.700 -> javax.annotation:javax.annotation-api:jar:[1.3.5,2.0.0): No versions available for javax.annotation:javax.annotation-api:jar:[1.3.5,2.0.0) within specified range ]

it seems that was maven dependency problem. I can only get javax.annotaion-api.1.3.2 from maven repository. Can any body help me on this ?

1 Like

I have the same problem since updating from Katalon version 7.9.0 to 7.9.1

solved my problem by stop depending on katalon.platform

Same problem here, unable to package my plugin in Eclipse with Maven

Hi guys,

Please use com.katalon.platform.parent and com.katalon.platform version 1.0.17

This worked for me, perfect, thanks.