Bamboo Chromedriver

Working on integrating Katalon with Bamboo and I’ve come across an error that I cannot seem to solve.

2019-05-01 22:16:43.453 ERROR c.k.k.core.keyword.internal.KeywordMain - ? Unable to open browser with url: ‘’ (Root cause: com.kms.katalon.core.exception.StepFailedException: Unable to open browser with url: ‘’
simple 01-May-2019 22:16:57 at com.kms.katalon.core.webui.keyword.internal.WebUIKeywordMain.stepFailed(WebUIKeywordMain.groovy:64)
simple 01-May-2019 22:16:57 at com.kms.katalon.core.webui.keyword.internal.WebUIKeywordMain.runKeyword(WebUIKeywordMain.groovy:26)
simple 01-May-2019 22:16:57 at com.kms.katalon.core.webui.keyword.builtin.OpenBrowserKeyword.openBrowser(OpenBrowserKeyword.groovy:81)
simple 01-May-2019 22:16:57 at com.kms.katalon.core.webui.keyword.builtin.OpenBrowserKeyword.execute(OpenBrowserKeyword.groovy:67)
simple 01-May-2019 22:16:57 at com.kms.katalon.core.keyword.internal.KeywordExecutor.executeKeywordForPlatform(KeywordExecutor.groovy:56)
simple 01-May-2019 22:16:57 at com.kms.katalon.core.webui.keyword.WebUiBuiltInKeywords.openBrowser(WebUiBuiltInKeywords.groovy:60)
simple 01-May-2019 22:16:57 at com.kms.katalon.core.webui.keyword.WebUiBuiltInKeywords$openBrowser.call(Unknown Source)
simple 01-May-2019 22:16:57 at Fax.run(Fax:7)
simple 01-May-2019 22:16:57 at com.kms.katalon.core.main.ScriptEngine.run(ScriptEngine.java:194)
simple 01-May-2019 22:16:57 at com.kms.katalon.core.main.ScriptEngine.runScriptAsRawText(ScriptEngine.java:119)
simple 01-May-2019 22:16:57 at com.kms.katalon.core.main.TestCaseExecutor.runScript(TestCaseExecutor.java:336)
simple 01-May-2019 22:16:57 at com.kms.katalon.core.main.TestCaseExecutor.doExecute(TestCaseExecutor.java:327)
simple 01-May-2019 22:16:57 at com.kms.katalon.core.main.TestCaseExecutor.processExecutionPhase(TestCaseExecutor.java:306)
simple 01-May-2019 22:16:57 at com.kms.katalon.core.main.TestCaseExecutor.accessMainPhase(TestCaseExecutor.java:298)
simple 01-May-2019 22:16:57 at com.kms.katalon.core.main.TestCaseExecutor.execute(TestCaseExecutor.java:232)
simple 01-May-2019 22:16:57 at com.kms.katalon.core.main.TestSuiteExecutor.accessTestCaseMainPhase(TestSuiteExecutor.java:129)
simple 01-May-2019 22:16:57 at com.kms.katalon.core.main.TestSuiteExecutor.accessTestSuiteMainPhase(TestSuiteExecutor.java:112)
simple 01-May-2019 22:16:57 at com.kms.katalon.core.main.TestSuiteExecutor.execute(TestSuiteExecutor.java:81)
simple 01-May-2019 22:16:57 at com.kms.katalon.core.main.TestCaseMain.startTestSuite(TestCaseMain.java:157)
simple 01-May-2019 22:16:57 at com.kms.katalon.core.main.TestCaseMain$startTestSuite$0.call(Unknown Source)
simple 01-May-2019 22:16:57 at TempTestSuite1556748999672.run(TempTestSuite1556748999672.groovy:35)
simple 01-May-2019 22:16:57 Caused by: java.lang.IllegalStateException: The driver is not executable: /var/atlassian/application-data/bamboo/6.1.2/configuration/resources/drivers/chromedriver_linux64/chromedriver

What this error states is that Katalon cannot open the chromedriver because it is not executable.

What I’ve done:
Permissions: chmod 777 , chmod +x (All failed)
Chrome Driver Version: ChromeDriver 73.0.3683.68
Katalon Version: 6.1.2

Note: The documentation will not explain that the Katalon plugin will not run out of the box. You will need to download the headless Katalon Linux package, unzip it, and install it in Katalon’s default working directory.

Once done, run the Katalon script of your choosing, how did your result differ?

Hi @amari.matthews,

You integrate Katalon and Bamboo by configuring manually or using Bamboo plugin?. If you do it manually, could you tell me detail steps?.

I integrated Katalon via the plugin and received a fatal error.

First the plugin install went very smoothly. No issues.

Second, we copied the test suite package as explained in the documentation.==> https://docs.katalon.com/katalon-studio/docs/bamboo-integration.html#prerequisites

Third, ran the pipeline. Error received ==> ERROR c.k.k.core.keyword.internal.KeywordMain - ? Unable to open browser with url: ‘’ (Root cause: com.kms.katalon.core.exception.StepFailedException: Unable to open browser with url: ‘’
^^ We have no idea why. The script runs perfectly on Windows or Mac versions of Katalon and on multiple versions. So we started an investigation as to why.

Then we found this:
Caused by: java.lang.IllegalStateException: The driver is not executable: /var/atlassian/application-data/bamboo/6.1.2/configuration/resources/drivers/chromedriver_linux64/chromedriver

^^Confusing, as the driver at that path works just fine.

Even when done manually, I copied the unziped Katalon Studio for Linux into /var/atlassian/application-data/bamboo/6.1.2/katalon which is where it was trying to execute the Katalon Studio. Doesn’t work, still we receive the same error as above.

I even manually ./chromedriver just to see if it is executable, and it is. Runs perfectly.
So now my question is what exactly is going on and what am I missing that the documentation missed? How do we prevent this from happening to others and how do we get the test suite to run on a CI pipeline?

We have also found that when we run the test suite with headless Firefox, it looks for the chrome binary. How weird is that?

Hi,
We will release a fixed version for this issue. Thanks for your contribution.

Please try updating the plugin to 1.3.0 and see if the issue has been resolved.

We updated the plugin and we have gotten the same error. This will make you laugh.

Caused by: org.openqa.selenium.WebDriverException: unknown error: cannot find Chrome binary
simple 07-May-2019 15:53:42 (Driver info: chromedriver=2.43.600233 (523efee95e3d68b8719b3a1c83051aa63aa6b10d),platform=Linux 4.15.0-1040-azure x86_64) (WARNING: The server did not provide any stacktrace information)

^^How can it not find the Chromedriver but it can pull the version? This doesn’t make sense.

Here is some more information:
Use a Docker Container
Download Katalon Version : 6.0.6 <===Do not use the latest version. It will break before execution.

Command:
-projectPath="/var/atlassian/application-data/bamboo/Demo/Demo.prj" -testSuitePath="/Test Suites/Plan 9" -browserType=“Chrome”

The error with Chrome driver is related to control the Chrome. This error is related to missing Chrome in your environment. Please make sure if you installed Chrome in your environment.

I appreciate the double check but I wouldn’t have though to ever post on a forum if I did not ensure all the proper steps were completed and frankly it was a bit condescending.

If you look above, the chrome binary is there. Otherwise, the version would not be displayed at all.

The binary is executable, and for several different operating systems.

That was the version of ChromeDriver. ChromeDriver is a binary that control Chrome, but it’s not Chrome. Chrome have to be installed separately just like Firefox etc. Normally in Ubuntu you can install it with the following commands

wget -O google-chrome-stable_current_amd64.deb https://dl.google.com/linux/direct/google-chrome-stable_current_amd64.deb
dpkg -i google-chrome-stable_current_amd64.deb || apt -y -f install