AppiumDriver<?> driver = MobileDriverFactory.getDriver() I have added appium driver command. But unbale to run the code, See the below message

For printing elements under a list in mobile category I have added command for appium driver. Bu it is showing error as

Test Cases/LoginJoinHiveDetailViewTC FAILED.
com.kms.katalon.core.exception.StepFailedException: Unable to start app at: ‘C:\Users\Archana\Downloads\app-production-release (3).apk’ (Root cause: com.kms.katalon.core.appium.exception.AppiumStartException: Appium directory is invalid: Cannot find appium executable file.

Please help

@archana0393 It might be that you have not set the path to your appium installation inside katalon studio. Check where you have appium installed and which version you have (there are special instructions for setup if you want to use appium 2.0 or above) and then make sure you add the path to katalon preferences under Preferences → Katalon → Mobile.

I tried “where appium” command in cmd
it is showing below result


But when I tried “appium -v” it is showing below error
throw err;

Error: Cannot find module ‘C:\Users\Archana\AppData\Roaming\npm\node_modules\appium\build\lib\main.js’
←[90m at Function.Module._resolveFilename (node:internal/modules/cjs/loader:933:15)←[39m
←[90m at Function.Module._load (node:internal/modules/cjs/loader:778:27)←[39m
←[90m at Function.executeUserEntryPoint [as runMain] (node:internal/modules/run_main:81:12)←[39m
←[90m at node:internal/main/run_main_module:17:47←[39m {
code: ←[32m’MODULE_NOT_FOUND’←[39m,

Please help

@archana0393 How did you install appium? It looks like the installation was not successful so I would try to uninstall it and reinstall it again to see if that will fix the issue.


Seems like these are relevant: