Any way to test Single Sign on Apps ? any workaround or help would be appreciated


#1

Team,

I am looking for help with SSO testing. I added delay it works for than failed for most of items. any one can help with work around?


#2

Please provide more details, thanks.


#3

Brandon-

I am asking for Single Sign on if you read the request . And Single Sign on is standard log in mechanism across the IT industry . So if your are not aware. I can throw some light in that context…
Try logging into any job portal where u try to apply and then u select a portal and it says login using linkdin credentials . so that kind of scenario. I can share script only if ur tools records that steps .it never does so .let me know if you have time to do screen share .


#4

Kind of. It’s an umbrella term with a myriad different possibilities.

But let’s be clear. Katalon Studio in the main tests web-based systems running in a browser.

So, if your scenario is running in a browser, using web-native tech (i.e. HTML, CSS, JavaScript), there should not be a problem (nothing beyond the regular everyday problems we all suffer from time to time).

Now to your question, please, act on this:

We need to see broken lines of code, errors, HTML examples and screenshots.

What’s so hard to understand about that? Your scenario is very likely nothing like mine. But even so, here’s my line of code which just happens to work with SSO.

login( (Map) ssoCredentials)

That was sarcasm, btw. :open_mouth:


#5

No thanks, I’m perfectly familiar with SSO :smile: That being said, with the amount of detail that you’ve presented for your issue, we cannot possibly offer any suggestions, hence the topic that I linked.


#6

Brandon . if you dont wanna help, that fine with me ,butyou don’t have to be rude. I Believe you must be some hot shot of ur company that why behaving in such rude manner and rather than helping with request acting all strange.

I simply replied if i cant capture SSO how i can send u ato ran script. so thanks but no thanks will figure out fix my self .Mr Newton


#7

I’m being rude for asking for more information? If I didn’t want to help you, I wouldn’t have responded to your post in the first place.


#8

There are many things relating to SSO testing, and we could not provide the whole setup, script, solution for testing it. Let’s us know what your current script is, which issue you have now and what you want to do next. Some screenshot, error message when running your script would help.


#9

Ok,
so from high level perspective:

  1. gather information how SSO is working in your company (headers, cookies, other…) based on MS AD/kerberos/combination of other things?
  2. implement solution to your tests (e.g. test users in AD, getting header records and use them, prepare cookies)

your question is quite wide, so there will be no specific answer until you provide more details…


#10

Hello ,
Unfortunately I am unable to share logs but here is my scenario where I will appreciate some help.

Firstly I login to my internal application , say App1.
This application has Qlik Sense tool integrated and I can access it through one of its menu ; let us call the Qlik Sense app as App2.
Using object repository I captured all the objects of APP1 and App2.
I recorded my steps to navigate from App1 to App2 . However when I play my test, only the steps related to App1 are successful as the objects are identified.
For the moment, as a workaround I am providing the urls of App2 objects but I am still not able to run the test successfully due to errors related to objects not found.

Please note that when I record objects using Spyweb, i am providing the url of App1 and I am able to verify the objects (objects found). But for App2, since the url is that of App1’s, I am unable to verify them as the Spyweb is trying to find the object on the url of App1 (which is expected). I think this is where the issue lies.

Any insights on how we could handle this scenario would be of much help as I am not very familiar with automation tools and spending spent too much time investigating this.

Thank you in advance !


#11

is app2 opening as separate tab? window? or as embeded iframe?


#12

App2 opens in a new tab of the same window.


#13

in that case i think you need to switch window … please take a look here:


#14

Thanks Andrej,
Yes, switching to windows helped but I could not use the objects that were recorded using the Object spy. So as a workaround I manually added test object ,provided absolute xpaths and removed all the other attributes that were recorded.
Also between switching windows and clicking on different menu items and I had to use ,Wait For Angular Load’, ‘Delay’, ‘Wait for Element clickable’ etc


#15

good job, congratulation :grinning: