After updating to 5.1.0.1 existing cases will not run in firefox

Existing, working tests now no longer start under the latest version of Katalon, below s a bit from the log. NB. the PC is running latest version of Firefox Quantum

11-20-2017 02:30:18 PM - [INFO] - Starting ‘Firefox’ driver
11-20-2017 02:30:18 PM - [WARNING] - org.openqa.selenium.firefox.FirefoxDriver.(Lorg/openqa/selenium/firefox/FirefoxOptions;)V
11-20-2017 02:30:18 PM - [FAILED] - Unable to open browser with url: ‘’ (Root cause: java.lang.NoSuchMethodError: org.openqa.selenium.firefox.FirefoxDriver.(Lorg/openqa/selenium/firefox/FirefoxOptions;)V)
11-20-2017 02:30:18 PM - [END] - End action : openBrowser

Can I ask which Firefox version you are using? I’ve no problems from my side, and where do you download that version?

I have the same Problem.
Katalon Studio 5.1.0.1 and Firefox 57.0 (64-Bit)

Error message:
Test Cases/New Test Case FAILED because (of) Unable to open browser with url: ‘’ (Root cause: java.lang.NoSuchMethodError: org.openqa.selenium.firefox.FirefoxDriver.(Lorg/openqa/selenium/firefox/FirefoxOptions;)V)

Well I can’t seem to be able to reproduce it. I see my FF is currently 58, can you try with it? Or is it possible to attach your project here?

Yes me too I am using FF v 57 but simple recording from Chrome won’t run…

Code#


import static com.kms.katalon.core.checkpoint.CheckpointFactory.findCheckpoint
import static com.kms.katalon.core.testcase.TestCaseFactory.findTestCase
import static com.kms.katalon.core.testdata.TestDataFactory.findTestData
import static com.kms.katalon.core.testobject.ObjectRepository.findTestObject
import com.kms.katalon.core.checkpoint.Checkpoint as Checkpoint
import com.kms.katalon.core.checkpoint.CheckpointFactory as CheckpointFactory
import com.kms.katalon.core.mobile.keyword.MobileBuiltInKeywords as MobileBuiltInKeywords
import com.kms.katalon.core.mobile.keyword.MobileBuiltInKeywords as Mobile
import com.kms.katalon.core.model.FailureHandling as FailureHandling
import com.kms.katalon.core.testcase.TestCase as TestCase
import com.kms.katalon.core.testcase.TestCaseFactory as TestCaseFactory
import com.kms.katalon.core.testdata.TestData as TestData
import com.kms.katalon.core.testdata.TestDataFactory as TestDataFactory
import com.kms.katalon.core.testobject.ObjectRepository as ObjectRepository
import com.kms.katalon.core.testobject.TestObject as TestObject
import com.kms.katalon.core.webservice.keyword.WSBuiltInKeywords as WSBuiltInKeywords
import com.kms.katalon.core.webservice.keyword.WSBuiltInKeywords as WS
import com.kms.katalon.core.webui.keyword.WebUiBuiltInKeywords as WebUiBuiltInKeywords
import com.kms.katalon.core.webui.keyword.WebUiBuiltInKeywords as WebUI
import internal.GlobalVariable as GlobalVariable
import org.openqa.selenium.Keys as Keys

WebUI.openBrowser(’’)

WebUI.navigateToUrl(‘https://auth.ultimatix.net/utxLogin/login?TYPE=33554432&REALMOID=06-45402d83-8994-41d4-9e1e-60a2815da6a3&GUID=&SMAUTHREASON=0&METHOD=GET&SMAGENTNAME=-SM-EdbHMX6T%2BWb8DN7DVmL5sbY%2Bn%2B30S7n%2FgIBptYa9dLbudResX4AYm9ObPeNozoDH&TARGET=-SM-HTTPS%3A%2F%2Fwww.ultimatix.net%2FultimatixPortalWeb%2FUTXPortalRedirect%3FTARGET%3Dhttps-%3A-%2F-%2Fwww.ultimatix.net-%2F’)

WebUI.setText(findTestObject(‘Page_Ultimatix - Digitally Connecte (1)/input_USER’), ‘blah’)

WebUI.setText(findTestObject(‘Page_Ultimatix - Digitally Connecte (1)/input_PASSWORD’), ‘bhab’)

WebUI.click(findTestObject(‘Page_Ultimatix - Digitally Connecte (1)/input_login_button’))

WebUI.closeBrowser()

Problem 2:

I tried extending my recording beyond these steps but I think the recording cannot identify switch to different windows and actions taken in code, it just generates the click actions. But the strange thing is that when I click OK after the recording I get the error message “Error in generating the Test scripts”.

Could you please have a look at the same

I’ve installed Katalon Studio 5.1.0.2 completely new. So now it works with FF 57.0 (64-Bit).

Hi P.pohlman, did you delete old Katalon Studio and install new one? Did you have to make any changes in order to make it work?