Unknown error: cannot find Chrome binary

kazurayam said:


You mentioned at 05/01/2018 that:

Tried this but still getting the same error on Spy Web or Record Web.

Have you installed Katalon Addon for Chrome? The document states that the addon is required for Spy Web and Record Web.

Yes I did, now i have asked my tech team to see if there’s any network issue restricting it.

The following post shows you how to get chromedriver.log file:

In the chromedriver.log you can find a command line with which Katalon Studio started chrome.exe. For example:

[1526012674.637][INFO]: Launching chrome: "C:\Program Files (x86)\Google\Chrome\Application\chrome.exe"     --disable-background-networking     --disable-client-side-phishing-detection     --disable-default-apps --disable-hang-monitor     --disable-popup-blocking --disable-prompt-on-repost     --disable-sync --disable-web-resources     --enable-automation --enable-logging     --force-fieldtrials=SiteIsolationExtensions/Control     --ignore-certificate-errors     --load-extension="C:\Katalon_Studio_Windows_64-5.4.1\configuration\resources\extensions\Chrome\Object Spy,C:\Users\username\AppData\Local\Temp\scoped_dir10832_12653\internal"     --log-level=0 --metrics-recording-only --no-first-run     --password-store=basic     --remote-debugging-port=12067     --test-type=webdriver     --use-mock-keychain     --user-data-dir="C:\Users\username\AppData\Local\Temp\scoped_dir10832_25782" data:,

You might be interested in the switch


What is the remote-debugging-port? See


I have a doubt if your PC might be strictly administrated by your network team so that any access to http://localhost:XXXXX is firewalled. If it is the case, Katalon Studio would not be able to communicate with Chrome.

kazurayam your fix worked great for me. Thank you so much.


Glad to hear your success. I would like to know what kind of problem you had and what portion of my comments helped you. Is your PC strictly administrated by your network team so that any access to local host is prohibited? How is the firewall implemented? Would you like to tell us about your case just for our information?

Hi @kazurayam

I am trying to run my test suite on jenkins. Just a quick question though. do i still need to explicitly set the path on my code even if i already have my set-up my binary in the desired capabilities section of the project?

below is a snippet of my result, where-in you can see that the binary is set but is still having errors looking for the chrom binary

2019-04-25 02:06:53.410 INFO c.k.katalon.core.main.TestSuiteExecutor - START Test Suites/GMA.E2E.Login Page
2019-04-25 02:06:53.480 INFO c.k.katalon.core.main.TestSuiteExecutor - hostName = GMAEEAUTO-WVM$ - GMAEEAUTO-WVM.jene3dwzkssebmwdnk5e1y1s2a.ix.internal.cloudapp.net
2019-04-25 02:06:53.484 INFO c.k.katalon.core.main.TestSuiteExecutor - os = Windows Server 2016 64bit
2019-04-25 02:06:53.484 INFO c.k.katalon.core.main.TestSuiteExecutor - hostAddress =
2019-04-25 02:06:53.485 INFO c.k.katalon.core.main.TestSuiteExecutor - katalonVersion =
2019-04-25 02:06:54.056 INFO c.k.katalon.core.main.TestCaseExecutor - --------------------
2019-04-25 02:06:54.056 INFO c.k.katalon.core.main.TestCaseExecutor - START Test Cases/LoginUsingValidAccount
Start recording video for test case ‘Test Cases/LoginUsingValidAccount’.
2019-04-25 02:06:55.109 DEBUG testcase.LoginUsingValidAccount - 1: openBrowser("")
2019-04-25 02:06:55.420 INFO c.k.k.core.webui.driver.DriverFactory - Starting ‘Chrome’ driver
2019-04-25 02:06:55.438 INFO c.k.k.c.w.util.WebDriverPropertyUtil - User set preference: [‘chrome.binary’, ‘C:\Users\ulautomationadmin\AppData\Local\Google\Chrome\Application\chrome.exe’]
2019-04-25 02:06:55.465 INFO c.k.k.core.webui.driver.DriverFactory - Action delay is set to 0 seconds
Starting ChromeDriver 73.0.3683.68 (47787ec04b6e38e22703e856e101e840b65afe72) on port 49326
Only local connections are allowed.
Please protect ports used by ChromeDriver and related test frameworks to prevent access by malicious code.
2019-04-25 02:06:57.999 ERROR c.k.k.core.keyword.internal.KeywordMain - ? Unable to open browser with url: ‘’ (Root cause: com.kms.katalon.core.exception.StepFailedException: Unable to open browser with url: ‘’
at com.kms.katalon.core.webui.keyword.internal.WebUIKeywordMain.stepFailed(WebUIKeywordMain.groovy:64)
at com.kms.katalon.core.webui.keyword.internal.WebUIKeywordMain.runKeyword(WebUIKeywordMain.groovy:26)
at com.kms.katalon.core.webui.keyword.builtin.OpenBrowserKeyword.openBrowser(OpenBrowserKeyword.groovy:81)
at com.kms.katalon.core.webui.keyword.builtin.OpenBrowserKeyword.execute(OpenBrowserKeyword.groovy:67)
at com.kms.katalon.core.keyword.internal.KeywordExecutor.executeKeywordForPlatform(KeywordExecutor.groovy:56)
at com.kms.katalon.core.webui.keyword.WebUiBuiltInKeywords.openBrowser(WebUiBuiltInKeywords.groovy:60)
at com.kms.katalon.core.webui.keyword.WebUiBuiltInKeywords$openBrowser.call(Unknown Source)
at LoginUsingValidAccount.run(LoginUsingValidAccount:18)
at com.kms.katalon.core.main.ScriptEngine.run(ScriptEngine.java:194)
at com.kms.katalon.core.main.ScriptEngine.runScriptAsRawText(ScriptEngine.java:119)
at com.kms.katalon.core.main.TestCaseExecutor.runScript(TestCaseExecutor.java:342)
at com.kms.katalon.core.main.TestCaseExecutor.doExecute(TestCaseExecutor.java:333)
at com.kms.katalon.core.main.TestCaseExecutor.processExecutionPhase(TestCaseExecutor.java:312)
at com.kms.katalon.core.main.TestCaseExecutor.accessMainPhase(TestCaseExecutor.java:304)
at com.kms.katalon.core.main.TestCaseExecutor.execute(TestCaseExecutor.java:238)
at com.kms.katalon.core.main.TestSuiteExecutor.accessTestCaseMainPhase(TestSuiteExecutor.java:129)
at com.kms.katalon.core.main.TestSuiteExecutor.accessTestSuiteMainPhase(TestSuiteExecutor.java:112)
at com.kms.katalon.core.main.TestSuiteExecutor.execute(TestSuiteExecutor.java:81)
at com.kms.katalon.core.main.TestCaseMain.startTestSuite(TestCaseMain.java:157)
at com.kms.katalon.core.main.TestCaseMain$startTestSuite$0.call(Unknown Source)
at TempTestSuite1556158009036.run(TempTestSuite1556158009036.groovy:35)
Caused by: org.openqa.selenium.WebDriverException: unknown error: cannot find Chrome binary
(Driver info: chromedriver=73.0.3683.68 (47787ec04b6e38e22703e856e101e840b65afe72),platform=Windows NT 10.0.14393 x86_64) (WARNING: The server did not provide any stacktrace information)
Command duration or timeout: 342 milliseconds


What do you mean by this?
Could you share a screenshot of the dialog where you put the Chrome-binary path?


here is a screeshot

Desired Capabilities is not appropriate place to specify the Chrome binary path.


in version 6.1.1, there is no option under execution. which then lead me to the desired capabilities since on the manual code above it is stated that
DesiredCapabilities capabilities = new DesiredCapabilities();
capabilities.setCapability(ChromeOptions.CAPABILITY, options);

Here are the screenshot of execution under project settings of v6.1.1

1 Like


Could you join us?

carlos sais “in version 6.1.1, there is no option under execution”.

How can we specify Chrome binary path in KS v6.1.1 GUI?

@kazurayam you meant this?

When I open the Project Settings > Execution dialong in v6.1.2, I could not find Execution > Default > Web UI > Chrome submenu any longer, as carlos mentioned at

Why Execution > Default > Web UI > Chrome submenu missing?

1 Like

I am seeing similar issue.
I am using windows 7 and I have just installed only chrome 85.0.4183.83 and katalon studio 7.6.6

Error details:
unknown error: cannot find chrome binary.

1 Like

I faced this problem too…
And already fixing with updatewebdrivers for chrome…
Hope you solved this problem also…

Does anyone know how to specify the path to the Chrome binary in recent Katalon Studio versions (8.1) where the above mentioned configuration Execution > Default > Web UI > Chrome doesn’t exist?

EDIT: Figured it out, it has to be set in Desired Capabilities > Web UI > Chrome via the binary option as desribed at https://chromedriver.chromium.org/capabilities

The only thing that annoys me is that it doesn’t seem to be possible to utilize some environment variable in the value.