Sign Up

nazneen said:

nazneen said:

okay Switch window is working still I get error.
Test Cases/Sign up for service provider FAILED because (of) Unable to switch to window with title: ‘Workilo :: Shop Setup’ (Root cause: Cannot find window with title: ‘Workilo :: Shop Setup’)

Also I have used this switch window because browser screen was not moved to the next page i.e. shop creation page. I dont know either it will be correct to use it here or not?
Here are the screen:

@Can anyone help me out on this scenario? I am totally stuck into it :frowning:

is that really separate window?

No its not separate window. I have notice click button is not working. I have used custom keywords still its not working but the test cases passed but screen not moved also click button is not pressed. Please help

How can I resolve element not visible command?
here are the error details:

Test Cases/Sign up for service provider FAILED because (of) Unable to click on object ‘Object Repository/sign up for service provider recording/Page_Workilo Welcome/input_button’ (Root cause: org.openqa.selenium.ElementNotVisibleException: element not visible

(Session info: chrome=67.0.3396.99)

(Driver info: chromedriver=2.35.528161 (5b82f2d2aae0ca24b877009200ced9065a772e73),platform=Windows NT 6.3.9600 x86_64) (WARNING: The server did not provide any stacktrace information)

Command duration or timeout: 0 milliseconds

Build info: version: ‘3.7.1’, revision: ‘8a0099a’, time: ‘2017-11-06T21:07:36.161Z’

System info: host: ‘WINCTRL-I1MBNJ3’, ip: ‘192.168.0.56’, os.name: ‘Windows 8.1’, os.arch: ‘amd64’, os.version: ‘6.3’, java.version: ‘1.8.0_102’

Driver info: com.kms.katalon.selenium.driver.CChromeDriver

Capabilities {acceptInsecureCerts: false, acceptSslCerts: false, applicationCacheEnabled: false, browserConnectionEnabled: false, browserName: chrome, chrome: {chromedriverVersion: 2.35.528161 (5b82f2d2aae0ca…, userDataDir: C:\Users\ASSET-~1\AppData\L…}, cssSelectorsEnabled: true, databaseEnabled: false, handlesAlerts: true, hasTouchScreen: false, javascriptEnabled: true, locationContextEnabled: true, mobileEmulationEnabled: false, nativeEvents: true, networkConnectionEnabled: false, pageLoadStrategy: normal, platform: XP, platformName: XP, rotatable: false, setWindowRect: true, takesHeapSnapshot: true, takesScreenshot: true, unexpectedAlertBehaviour: , unhandledPromptBehavior: , version: 67.0.3396.99, webStorageEnabled: true}

Session ID: 6050fd1850fc6410c76677dd5b9ea8a8)

nazneen,
i would like to see screenshot produced by that error (where to find it, was posted on some other threads created by you)

okay.Here it is.

Test Cases/Sign up for service provider FAILED because (of) Unable to click on object ‘Object Repository/sign up for service provider recording/Page_Workilo Welcome/input_button’ (Root cause: org.openqa.selenium.ElementNotVisibleException: element not visible

(Session info: chrome=67.0.3396.99)

(Driver info: chromedriver=2.35.528161 (5b82f2d2aae0ca24b877009200ced9065a772e73),platform=Windows NT 6.3.9600 x86_64) (WARNING: The server did not provide any stacktrace information)

Command duration or timeout: 0 milliseconds

Build info: version: ‘3.7.1’, revision: ‘8a0099a’, time: ‘2017-11-06T21:07:36.161Z’

System info: host: ‘WINCTRL-I1MBNJ3’, ip: ‘192.168.0.56’, os.name: ‘Windows 8.1’, os.arch: ‘amd64’, os.version: ‘6.3’, java.version: ‘1.8.0_102’

Driver info: com.kms.katalon.selenium.driver.CChromeDriver

Capabilities {acceptInsecureCerts: false, acceptSslCerts: false, applicationCacheEnabled: false, browserConnectionEnabled: false, browserName: chrome, chrome: {chromedriverVersion: 2.35.528161 (5b82f2d2aae0ca…, userDataDir: C:\Users\ASSET-~1\AppData\L…}, cssSelectorsEnabled: true, databaseEnabled: false, handlesAlerts: true, hasTouchScreen: false, javascriptEnabled: true, locationContextEnabled: true, mobileEmulationEnabled: false, nativeEvents: true, networkConnectionEnabled: false, pageLoadStrategy: normal, platform: XP, platformName: XP, rotatable: false, setWindowRect: true, takesHeapSnapshot: true, takesScreenshot: true, unexpectedAlertBehaviour: , unhandledPromptBehavior: , version: 67.0.3396.99, webStorageEnabled: true}

Session ID: 9f0566b96a5064db29e9e05b0c1759f7)

My code:

WebUI.waitForElementVisible(findTestObject(‘sign up for service provider recording/Page_Workilo Welcome/input_button’), 5, FailureHandling.STOP_ON_FAILURE)

WebUI.waitForElementClickable(findTestObject(‘sign up for service provider recording/Page_Workilo Welcome/input_button’), 5, FailureHandling.STOP_ON_FAILURE)

WebUI.click(findTestObject(‘sign up for service provider recording/Page_Workilo Welcome/input_button’))

This Element not visible… error have been always resolved when I use custom keywords but this time it has some peculiar result. Test case passes but still button is not clicked.

Here the the error:

bugs on click.png

nazneen said:

This Element not visible… error have been always resolved when I use custom keywords but this time it has some peculiar result. Test case passes but still button is not clicked.

Here the the error:

signup button.png

so why you checking object with name “input shop name”?

that was my next step. Since sign up button is not working so that object is not able to find hence test cases fail. But my main concern is why my custom keyword code is passed but in browser sign up button is not clicked in ?

Oh Yes got the error. thanks for raising this question. there was some problem as I have left one field and may be that’s d reason this error shows again and again. Thanks Andrej again for your help. i am very impressed the way you answer our queries. Thanks alot.

1 Like

you are welcome

1 Like