Problem with SSN field

tried with the above code and used the other events as well. SSN is printing in the test box now with dashes but failing. here are the logs
Logviewer:
unable to execute java script

console:
onchange/onblur/unmask…is not a function

info:added the import org.openqa.selenium.JavascriptExecutor package but facing with the same error

Try .blur() instead of .onblur()

In future, PASTE the WHOLE error. You can of course strikeout anything you consider sensitive or private.

and kindly use code formating. is not that hard to add three backticks above & after the code/log sample
LE: or just a backtick for inline commands

1 Like

@usekatalon

Please understand, the root problem is actually trivial. Solving it is proving difficult due to lack of adherence to the best advice given below. If this continues, I’m going to back off – which is NOT what I want to do or what we do around here. We like to help.

Study this and please adopt the advice:

1 Like

adding to this:
… please have in mind that we do this in our free time.
we have also families, jobs and so on.
so … help us to help you :slight_smile:

@usekatalon

Highlight the SSN field in the Inspector (Firefox, please). Then try these again in the browser console. You should see output VERY similar.

You enter everything after each >>

image

onchange does not exist (null), but blur and onblur do exist (functions that return undefined).

thanks alot Russ for your support. its working fine now after removed the ssn.onblur(); line.

1 Like