Plugin are not getting installed?


I was trying to install jMeter integration plugin into my katalon from the store, when i re-loaded plugins i saw only 2 installed, i went back to katalon store website and it says that the plugin is active, why dont i see it then? Im not sure if its working, also what about the other ones that are not showing?


1 Like

I have seen exactly the same incident.


Katalon Team, are you aware of it?


I happened to find the cause of the problem: jMeter plugin and Basic Report plugin are not installed in my KS 7.8.2.

Basic Report plugin’s change log shows that the plugin has “Max KS Version” to be 7.6.10.

jMeter plugin’s change log shows that the plugin has “Max KS version” to be 6.9.10.

I have Katalon Studio ver 7.8.2. It is understandable that these plugins are NOT installed because of the “Max KS version” settings.

I also checked the change log of Excel keywords plugin and found it does not have “Max KS version” defined. I could install it to my KS 7.8.2.

I downgraded Katalon Studio to ver7.6.6 and installed the Basic Report. It worked fine.

This experiment suggests that “Max KS version” matters.

I would suggest Katalon Team to erase Max KS Version for Basic Report plugin and jMeter plugin.

One problem remains. When I tried to install the jMeter plugin into KS 7.8.2, Katalon Store showed that the plugin was successfully installed, the “Manage plugin” web page showed that I should have the plugin installed, but actually not due to MaxKSversion setting.

It seems that the Katalon Store’s Plugin installation process is not careful enough. It does not make sure if the plugin was actually installed into KS. It seems naively assume a successful installation will be done once it was requested. I suppose this design is too opportunistic.

And certain plugins are poorly maintained!

1 Like

According to

it says:

  • Install the Basic Reports plugin automatically for all users

Then the “max KS version” property of the Basic Reports plugin is just ignored.


The value of “7.6.10” as the max KS version of the Basic Reports plugin just confused me.