Chrome failed to start: exited normally

Hello everyone!

For those facing the update chromedriver (or any other browser driver) error, this solution worked for me and avoids the need to update manually the driver on each new build of browser:

Download newest version of Boni’s WDM fat .jar:
webdrivermanager-5.6.4-fat.jar

Then add that file to each project via Katalon Studio > Project > Settings > Library Management:

To test it, create a test case with:

import org.openqa.selenium.WebDriver
import org.openqa.selenium.chrome.ChromeDriver

import io.github.bonigarcia.wdm.WebDriverManager

WebDriverManager.chromedriver().setup()

WebDriver driver = new ChromeDriver()

Hope that helps.

All the other solutions 1-3 did not work for me. Probably because I am using the Mac Silicon (mac-arm64) version and it is just different. If you put the downloaded version from link ( * mac-arm64: https://storage.googleapis.com/chrome-for-testing-public/121.0.6167.85/mac-arm64/chromedriver-mac-arm64.zip) in this directory on mac, then it may be workaround #4 for you too.
/Applications/Katalon Studio Arm64.app/Contents/Eclipse/configuration/resources/drivers/chromedriver_mac

1 Like

@roberto.flores

Thank you for your input.
I tried your suggestion, and confirmed the test case script you suggested worked as reported.


I want to remark that @roberto.flores’ suggestion does not fix the problem; the “Tools > Update WebDrivers > Chrome” still fails.

This implies that @robetor.flores’ suggestion does not help those who have their projects already on their CI/CD pipeline. Their CI/CI pipelines are failing since last week. Even if they put the latest version of webdrivermanager jar into the Drivers folder, their pipeline will continue to fail. They would not like to change their Test Case scripts in the way @roberto.flores suggested.

They require some other remedy that requires very litte change to their existing Test Case scripts they have developed.

Possibly yes.

However, kindly let me make a remark, the Chrome browser will auto-upgrade itself again and again in the near future. Next week? the week after the next? Possibly sometime next month. Then you will encounter the same trouble. The nightmare lasts.

So, I would suggest you to switch to “Chrome for Testing” as I wrote in the following:

though this approach requires you to change your test scripts to some extent.


If Katalon change their products as I described here: Chrome failed to start: exited normally - #29 by kazurayam, then you would not have to change your Test Case scripts any more; you want manually install Chrome for Testing and associated ChromeDriver of the version you choose; you choose “Chrome for Testing (Headless)” instead of “Chrome (Headless)” for you test cases to run on; then go. Your CI/CD pipeline should revive and sustain long regardless how often Chrome browser is updated.

I know that there is already a planned fixed, but just to add to the urgency. I am rather blocked by this as well CI wise. For me not being able to programmatically update webdrivers is no good. With my local machine I am able to toss whatever webdrivers and manually fix it, but for the CI process my company has in place, that uses azure spot VMs where the chrome version is rather locked down.

It becomes a bit of a slog to figure out which Katalon version may or may not have a version of webdriver bundled with it that will work with the chrome browser version on the VM.

Does katalon just always install the latest webdrivers when installing or does each version already have the driver in the correct location?

About which version of Katalon Runtime Engine do you want a reply from Katalon people?

  1. the current latest v9.3.0 and older, which is in a troble at the moment
  2. v9.3.1 which Katalon announced a planned release by the end of February this year
  3. some future versions after v9.3.1

@bhavyansh.ameta
@Elly_Tran

Your attention to this query, please.

@kazurayam, I agree with your overall solutions. The quick fix I did was to get me to the point I could run my regression scripts local to get some testing done for the release. I was down for over 2 months last year while this same issue was being ‘fixed’ at Katalon Studio. I want very much to introduce Katalon to our CI/CD pipeline with Cypress and load testing with JMeter, which seem to work continuously for us. Now that the release it done, I have time to explore these options while I am waiting for the ‘permanent’ fix from the product developers. As a one man show, I need Katalon to have my back and keep the product usable. If we took a couple of weeks or even a couple of hours to get our product up and running, we would be out of business.

who told you that?
i may have missed but there is no oficial announcements yet at the moment of writing …

There isn’t any official announcement yet. But I saw the following post:

I expect that the KS v9.3.1 will just bundle the newer version of webdrivermanager jar that supports the new URL format of ChromeDriver v121.0.6167.184 and newer. I expect no other changes.

Is Katalon going to do support for “Chrome for Testing” ? ---- I don’t know. They have commented nothing about the idea. They are silent.

I wonder why they are so determined to ignore “Chrome for Testing”. Do they think that my workaround would suffice? no need to change their product ? I don’t know.

I’ll cross my fingers for you.

This solution as well didnt worked for me :frowning:

@shraddha.borkar

It is not enough to say “didnt worked for me”. You should provide more information. At least you should show the error messages displayed in the console. That would tell the reason why the solution didnt worked for you. Otherwise, others can do nothing for you. We will just guess that you made some typing mistake.

forum announcements are not to be trusted, as history proved.
also, this will adress the issue only partly, as mentioned
and will not adress the issue for users willing to keep with older versions for some reason.
but looks like the squad support and the staff are, as always, bussy with whatever else, and letting only some representative in contact with the comunity.

this is more and more common, so i suppose the actual message is ‘comunity is just for fun but we don’t take it to seriously, since you don’ t pay. help each other’

OK. I will continue helping others.

I updated my Support “Chrome for Testing” project. The previous version instructed to place the Groovy source code of the com.kazurayam.ks.drivers.chrome4testing.ChromeForTesingDriverFactory class into the

Keywords

folder. On the other hand, as you may or may not be aware, the Keywords folder is exclusively available to the Enterprise users only as of KS v9.3.1. The Free plan users are excluded. So I revised the project so that it instructs you to place the same code into the

Include/scritpts/groovy

folder, which is (for now) available to the Free plan users as well. Support for “Chrome for Testing” is open. It doesn’t exclude the paying users. Take it free. :slightly_smiling_face:

However, I am afraid that the Katalon’s official support wouldn’t inform the paying 59997 customers of the idea :smiling_imp: because the support desk would not like to be asked “Why does Katalon Studio ignore Chrome for Testing?”.

Caused by: com.kms.katalon.core.exception.StepFailedException: Unable to open browser with url: ‘’

This is the same error which I had mentioned multiple times and in the main ticket as well.

Caused by: org.openqa.selenium.SessionNotCreatedException: session not created: Chrome failed to start: exited normally.
(session not created: DevToolsActivePort file doesn’t exist)
(The process started from chrome location C:\Program Files (x86)\Google\Chrome\Application\chrome.exe is no longer running, so ChromeDriver is assuming that Chrome has crashed.)
Build info: version: ‘3.141.59’, revision: ‘e82be7d358’, time: ‘2018-11-14T08:25:53’
System info: host: ‘ISWSTDDKP-001’, ip: ‘10.51.232.150’, os.name: ‘Windows Server 2019’, os.arch: ‘amd64’, os.version: ‘10.0’, java.version: ‘1.8.0_362’
Driver info: driver.version: CChromeDriver
remote stacktrace: GetHandleVerifier [0x002D1673+52979]
(No symbol) [0x00257961]
(No symbol) [0x0013DD3D]
(No symbol) [0x00165D1E]
(No symbol) [0x001612F9]
(No symbol) [0x0019D2B1]
(No symbol) [0x0019CE5A]
(No symbol) [0x00194286]
(No symbol) [0x0016C063]
(No symbol) [0x0016CECD]
GetHandleVerifier [0x005E8D83+3294723]
GetHandleVerifier [0x00626CC2+3548482]
GetHandleVerifier [0x00621C9C+3527964]
GetHandleVerifier [0x0036870E+671630]
(No symbol) [0x00261EB4]
(No symbol) [0x0025D808]
(No symbol) [0x0025D92D]
(No symbol) [0x0024F7E0]
BaseThreadInitThunk [0x771DFCC9+25]
RtlGetAppContainerNamedObjectPath [0x77C77C5E+286]
RtlGetAppContainerNamedObjectPath [0x77C77C2E+238]
(No symbol) [0x00000000]

at org.openqa.selenium.remote.W3CHandshakeResponse.lambda$errorHandler$0(W3CHandshakeResponse.java:62)
at org.openqa.selenium.remote.HandshakeResponse.lambda$getResponseFunction$0(HandshakeResponse.java:30)
at org.openqa.selenium.remote.ProtocolHandshake.lambda$createSession$0(ProtocolHandshake.java:126)
at org.openqa.selenium.remote.ProtocolHandshake.createSession(ProtocolHandshake.java:128)
at org.openqa.selenium.remote.ProtocolHandshake.createSession(ProtocolHandshake.java:74)
at org.openqa.selenium.remote.HttpCommandExecutor.execute(HttpCommandExecutor.java:136)
at org.openqa.selenium.remote.service.DriverCommandExecutor.execute(DriverCommandExecutor.java:83)
at org.openqa.selenium.remote.RemoteWebDriver.execute(RemoteWebDriver.java:552)
at com.kms.katalon.selenium.driver.CChromeDriver.execute(CChromeDriver.java:19)
at org.openqa.selenium.remote.RemoteWebDriver.startSession(RemoteWebDriver.java:213)
at org.openqa.selenium.remote.RemoteWebDriver.<init>(RemoteWebDriver.java:131)
at org.openqa.selenium.chrome.ChromeDriver.<init>(ChromeDriver.java:181)
at org.openqa.selenium.chrome.ChromeDriver.<init>(ChromeDriver.java:147)
at com.kms.katalon.selenium.driver.CChromeDriver.<init>(CChromeDriver.java:13)
at com.kms.katalon.core.webui.driver.DriverFactory.createNewChromeDriver(DriverFactory.java:441)
at com.kms.katalon.core.webui.driver.DriverFactory.startNewBrowser(DriverFactory.java:374)
at com.kms.katalon.core.webui.driver.DriverFactory.openWebDriver(DriverFactory.java:263)
at com.kms.katalon.core.webui.keyword.builtin.OpenBrowserKeyword$_openBrowser_closure1.doCall(OpenBrowserKeyword.groovy:74)
at com.kms.katalon.core.webui.keyword.builtin.OpenBrowserKeyword$_openBrowser_closure1.call(OpenBrowserKeyword.groovy)
at com.kms.katalon.core.webui.keyword.internal.WebUIKeywordMain.runKeyword(WebUIKeywordMain.groovy:20)
... 36 more

I’ve got an answer to this question of mine. See

2 Likes

Hi @here,

Thank you very much for your patience. Our Product team has released a fix for the issue with updating Chrome WebDriver in our latest release. You can learn more by visiting the thread below:

1 Like